summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-08-12 15:25:14 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-08-12 15:25:14 -0500
commitffb570ab318d2b9a1116a09cdcb1dc7a87762145 (patch)
tree52ccb9100663913cd76f9441f5d404ef78436545 /net-misc
parentmedia-sound/pulseaudio: remove package (diff)
downloadtamiko-ffb570ab318d2b9a1116a09cdcb1dc7a87762145.tar.gz
tamiko-ffb570ab318d2b9a1116a09cdcb1dc7a87762145.tar.bz2
tamiko-ffb570ab318d2b9a1116a09cdcb1dc7a87762145.zip
net-misc/udptunnel: add udptunnel
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/udptunnel/Manifest1
-rw-r--r--net-misc/udptunnel/files/udptunnel-1.1-strlen-prototype.patch16
-rw-r--r--net-misc/udptunnel/metadata.xml14
-rw-r--r--net-misc/udptunnel/udptunnel-1.1.ebuild27
4 files changed, 58 insertions, 0 deletions
diff --git a/net-misc/udptunnel/Manifest b/net-misc/udptunnel/Manifest
new file mode 100644
index 0000000..6fe9f42
--- /dev/null
+++ b/net-misc/udptunnel/Manifest
@@ -0,0 +1 @@
+DIST udptunnel-1.1.tar.gz 30910 SHA256 45c0e12045735bc55734076ebbdc7622c746d1fe4e6f7267fa122e2421754670 SHA512 9f9f978caede9085723c6222443b020b44d688e9364ffd57455cdfe0686d6f492e758c2ac502602cf4809ab28c3d47525e74feb00caa2b692358a272976eaa52 WHIRLPOOL 22d1b2b347aaea30390a2765a653623c600ac23490c451782cf3375cc574618b514f79bcbfcae697a4671ce4eabb70af098ee8a2f65d26fdcd27e4576c9c6537
diff --git a/net-misc/udptunnel/files/udptunnel-1.1-strlen-prototype.patch b/net-misc/udptunnel/files/udptunnel-1.1-strlen-prototype.patch
new file mode 100644
index 0000000..7a8b099
--- /dev/null
+++ b/net-misc/udptunnel/files/udptunnel-1.1-strlen-prototype.patch
@@ -0,0 +1,16 @@
+Description: Include string.h header for strlen prototype for GCC 4.4. compatibility.
+Author: Chris Lamb <chris@chris-lamb.co.uk>
+
+Taken from https://sources.debian.org/src/udptunnel/1.1-5/debian/patches/02-strlen-prototype.diff/
+
+diff -urNad /tmp/bp-build/udptunnel-1.1.orig.orig/host2ip.c /tmp/bp-build/udptunnel-1.1.orig/host2ip.c
+--- udptunnel-1.1.orig.orig/host2ip.c 2008-08-28 07:50:41.000000000 +0100
++++ udptunnel-1.1.orig/host2ip.c 2008-08-28 07:50:49.000000000 +0100
+@@ -6,6 +6,7 @@
+ #include <arpa/inet.h> /* inet_addr() */
+ #include <rpcsvc/ypclnt.h> /* YP */
+ #include <ctype.h> /* isspace() */
++#include <string.h> /* strlen() */
+
+ #include "host2ip.h"
+
diff --git a/net-misc/udptunnel/metadata.xml b/net-misc/udptunnel/metadata.xml
new file mode 100644
index 0000000..11831c8
--- /dev/null
+++ b/net-misc/udptunnel/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <longdescription lang="en">
+ UDPTunnel is a small program which can tunnel UDP packets
+ bi-directionally over a TCP connection. Its primary purpose (and
+ original motivation) is to allow multi-media conferences to traverse a
+ firewall which allows only outgoing TCP connections.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-misc/udptunnel/udptunnel-1.1.ebuild b/net-misc/udptunnel/udptunnel-1.1.ebuild
new file mode 100644
index 0000000..c9343c8
--- /dev/null
+++ b/net-misc/udptunnel/udptunnel-1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Tunnel UDP packets bi-directionally over a TCP connection"
+HOMEPAGE="http://www1.cs.columbia.edu/~lennox/udptunnel/"
+SRC_URI="http://www1.cs.columbia.edu/~lennox/udptunnel/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-devel/automake"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-strlen-prototype.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}