summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-08-05 23:13:00 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-08-05 23:13:00 +0900
commit005bee91e9df8ea7ef3e681bc0d288899975fba8 (patch)
treeff8180705856c84a15535d50b58faf0dc096d5d5
parentapp-i18n/libskk: sort eclasses (diff)
downloadgentoo-005bee91e9df8ea7ef3e681bc0d288899975fba8.tar.gz
gentoo-005bee91e9df8ea7ef3e681bc0d288899975fba8.tar.bz2
gentoo-005bee91e9df8ea7ef3e681bc0d288899975fba8.zip
app-i18n/libskk: update to EAPI 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--app-i18n/libskk/libskk-1.0.1.ebuild38
1 files changed, 18 insertions, 20 deletions
diff --git a/app-i18n/libskk/libskk-1.0.1.ebuild b/app-i18n/libskk/libskk-1.0.1.ebuild
index 6794948533ea..77cf687debec 100644
--- a/app-i18n/libskk/libskk-1.0.1.ebuild
+++ b/app-i18n/libskk/libskk-1.0.1.ebuild
@@ -1,49 +1,47 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
-VALA_MIN_API_VERSION="0.14"
-
-inherit virtualx vala
+inherit ltprune vala virtualx
DESCRIPTION="GObject-based library to deal with Japanese kana-to-kanji conversion method"
HOMEPAGE="https://github.com/ueno/libskk"
-SRC_URI="https://www.bitbucket.org/${PN}/${PN}/downloads/${P}.tar.gz"
+SRC_URI="https://bitbucket.org/${PN}/${PN}/downloads/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="nls +introspection static-libs"
+IUSE="+introspection nls static-libs"
-RDEPEND=">=dev-libs/glib-2.16
- dev-libs/libgee:0
+RDEPEND="dev-libs/glib:2
dev-libs/json-glib
- introspection? ( >=dev-libs/gobject-introspection-0.10.8 )
+ dev-libs/libgee:0
+ introspection? ( dev-libs/gobject-introspection )
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
$(vala_depend)
+ dev-util/intltool
virtual/pkgconfig
- nls? (
- dev-util/intltool
- sys-devel/gettext
- )"
-# doc? ( >=dev-util/valadoc-0.3.1 )
+ nls? ( sys-devel/gettext )"
-DOCS="ChangeLog NEWS README"
+src_prepare() {
+ vala_src_prepare
+ default
+}
src_configure() {
econf \
+ $(use_enable introspection) \
$(use_enable nls) \
- $(use_enable static-libs static) \
- $(use_enable introspection)
+ $(use_enable static-libs static)
}
src_test() {
- Xemake check || die "emake check failed."
+ virtx emake check
}
src_install() {
default
- rm -f "${ED}"/usr/lib*/lib*.la
+ prune_libtool_files
}