summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-25 22:16:02 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-25 22:20:43 +0200
commit011a513569497182d632fcbb967275e4169c3afd (patch)
treedecb6551450c5c5cb436b5ed00a616d5a5aa0815
parentdev-python/ply: Remove py2.7 (diff)
downloadgentoo-011a513569497182d632fcbb967275e4169c3afd.tar.gz
gentoo-011a513569497182d632fcbb967275e4169c3afd.tar.bz2
gentoo-011a513569497182d632fcbb967275e4169c3afd.zip
sci-electronics/kicad: Remove old (py2.7, drop to ~arch)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sci-electronics/kicad/Manifest4
-rw-r--r--sci-electronics/kicad/files/kicad-boost-1.61.patch347
-rw-r--r--sci-electronics/kicad/files/kicad-cmake-checkcxxsymbolexists.patch46
-rw-r--r--sci-electronics/kicad/files/kicad-footprints-cmakelists.txt16
-rw-r--r--sci-electronics/kicad/kicad-4.0.7-r1.ebuild198
-rw-r--r--sci-electronics/kicad/metadata.xml2
6 files changed, 0 insertions, 613 deletions
diff --git a/sci-electronics/kicad/Manifest b/sci-electronics/kicad/Manifest
index be5b223eb6f2..137d591a5480 100644
--- a/sci-electronics/kicad/Manifest
+++ b/sci-electronics/kicad/Manifest
@@ -1,6 +1,2 @@
-DIST kicad-4.0.7-i18n.tar.gz 2578242 BLAKE2B 610f580d9584cf9ef96686c3d7b7081d4c3a0d2c670482eaa2ef32720a7e71630670845a6050bae8e51df7ac41e30f73d3d11be65ea477ad9efd9fbb5176e2df SHA512 4880705fd7e95c939b7f5e2b7730fd37c426be10596f4cfa80d7df102d9e67232621900395d45f4e735986054f74fb215ae2002a2818faae32b1c75e3cb7e10a
-DIST kicad-4.0.7.tar.xz 10678656 BLAKE2B 54be9a3f5ae6378ac05cb327c28b1a358d895e736a116e1bf5151f021973b9510eab4671a67f222c3be2ef67929954b9576c5c28ef2b6a14708f8c019729969b SHA512 7b2acd9efadf5d48565f71bd0df2474ecc8fc04145953c13ac27363d48dbe6b0de091e311713635f603aed89ce0759a1d623abb37a139e2c87184ca4e717145b
DIST kicad-5.1.5.tar.xz 14203632 BLAKE2B cda7bf95c8edbddd36489f299dca9393ee51658e828f7e9f37bfa56955924785186908b0d8c91ae3e895f15cdba50c7579cf7a450e525f4a2ba215a721df26dd SHA512 5ca19e219da07a906f13e236849eb4497c9f827726a5cd13aceffe1d8c7dee480823bf3e949527f59a805eb3b8176fad51576ae663dd07b10e2822f2b37866a5
DIST kicad-5.1.6.tar.bz2 18299367 BLAKE2B b5bfda025bb0be249f2ff334e8b82c49e4e4265fe4cf5daad8a01bfd6149f4c2d1c55d689f3033136ab904f45e8deb9ea12ccde43ea083b14d92e677adf39c0f SHA512 4fd3d0ac1524cc113210be8dc1b76ab4e02bf271f598943ecab73af98a9dc99009b2d3818c97b358498d2f98ee863f13b21e958fd2143356c2a1368601f0d48a
-DIST kicad-footprints-4.0.7.tar.gz 4758012 BLAKE2B ca7ddcad3d1ca658d0d5b7c0a4a0e9a3906619bdbf14195b3bd14c528c01b6e9c1f185036ad495fc88a33a53040ae4d338230d8b2bbb598a69a1c07ddfec3cce SHA512 9ba08f528d4b3fa6f165a20333ad2e0f6bc4165b51da77bdb080ad2c8cc12c029927ddb2f6aa669b4dac5fac52b8bdbec803d1b7b3fc639e9481bb866b8e3d6f
-DIST kicad-library-4.0.7.tar.gz 475804416 BLAKE2B 0d6df1df7a72258e896552551996ff13e985976e03b6aafbe900dcc04c9b8eb6e5c1abc242ae5020c1bd20b51e9cc1e60f520b478954edcb6368db7f9ee46df0 SHA512 c5365e18e806102aace785895259deca708a61e0ce37262f5ee2482a8a1f86bc9ce1d37e0fb63cb0661bd5c71064ac36ca2260c9c02ed9790744eedd0a5b5360
diff --git a/sci-electronics/kicad/files/kicad-boost-1.61.patch b/sci-electronics/kicad/files/kicad-boost-1.61.patch
deleted file mode 100644
index 3ca8711b9f0a..000000000000
--- a/sci-electronics/kicad/files/kicad-boost-1.61.patch
+++ /dev/null
@@ -1,347 +0,0 @@
---- a/common/tool/tool_manager.cpp
-+++ b/common/tool/tool_manager.cpp
-@@ -532,11 +532,11 @@
- if( st->cofunc )
- st->Push();
-
-+ st->cofunc = new COROUTINE<int, const TOOL_EVENT&>( tr.second );
-+
- // as the state changes, the transition table has to be set up again
- st->transitions.clear();
-
-- st->cofunc = new COROUTINE<int, const TOOL_EVENT&>( tr.second );
--
- // got match? Run the handler.
- st->cofunc->Call( aEvent );
-
---- a/include/tool/coroutine.h
-+++ b/include/tool/coroutine.h
-@@ -27,10 +28,15 @@
-
- #include <cstdlib>
-
--#include <boost/context/fcontext.hpp>
- #include <boost/version.hpp>
-+#include <type_traits>
-
--#include "delegate.h"
-+#if BOOST_VERSION <= 106000
-+#include <boost/context/fcontext.hpp>
-+#else
-+#include <boost/context/execution_context.hpp>
-+#include <boost/context/protected_fixedsize_stack.hpp>
-+#endif
-
- /**
- * Class COROUNTINE.
-@@ -53,13 +59,12 @@
- * See coroutine_example.cpp for sample code.
- */
-
--template <class ReturnType, class ArgType>
-+template <typename ReturnType, typename ArgType>
- class COROUTINE
- {
- public:
- COROUTINE() :
-- m_saved( NULL ), m_self( NULL ), m_stack( NULL ), m_stackSize( c_defaultStackSize ),
-- m_running( false )
-+ COROUTINE( nullptr )
- {
- }
-
-@@ -69,8 +74,7 @@
- */
- template <class T>
- COROUTINE( T* object, ReturnType(T::* ptr)( ArgType ) ) :
-- m_func( object, ptr ), m_self( NULL ), m_saved( NULL ), m_stack( NULL ),
-- m_stackSize( c_defaultStackSize ), m_running( false )
-+ COROUTINE( std::bind( ptr, object, std::placeholders::_1 ) )
- {
- }
-
-@@ -78,9 +82,15 @@
- * Constructor
- * Creates a coroutine from a delegate object
- */
-- COROUTINE( DELEGATE<ReturnType, ArgType> aEntry ) :
-- m_func( aEntry ), m_saved( NULL ), m_self( NULL ), m_stack( NULL ),
-- m_stackSize( c_defaultStackSize ), m_running( false )
-+ COROUTINE( std::function<ReturnType(ArgType)> aEntry ) :
-+ m_func( std::move( aEntry ) ),
-+ m_running( false ),
-+#if BOOST_VERSION <= 106000
-+ m_stack( nullptr ),
-+ m_stackSize( c_defaultStackSize ),
-+#endif
-+ m_caller( nullptr ),
-+ m_callee( nullptr )
- {
- // Avoid not initialized members, and make static analysers quiet
- m_args = 0;
-@@ -89,18 +99,26 @@
-
- ~COROUTINE()
- {
-- if( m_saved )
-- delete m_saved;
--
- #if BOOST_VERSION >= 105600
-- if( m_self )
-- delete m_self;
-+ delete m_callee;
- #endif
-
-+#if BOOST_VERSION <= 106000
-+ delete m_caller;
-+
- if( m_stack )
- free( m_stack );
-+#endif
- }
-
-+private:
-+#if BOOST_VERSION <= 106000
-+ using context_type = boost::context::fcontext_t;
-+#else
-+ using context_type = boost::context::execution_context<COROUTINE*>;
-+#endif
-+
-+public:
- /**
- * Function Yield()
- *
-@@ -110,7 +128,12 @@
- */
- void Yield()
- {
-- jump( m_self, m_saved, 0 );
-+#if BOOST_VERSION <= 106000
-+ jump( m_callee, m_caller, false );
-+#else
-+ auto result = (*m_caller)( this );
-+ *m_caller = std::move( std::get<0>( result ) );
-+#endif
- }
-
- /**
-@@ -122,7 +145,11 @@
- void Yield( ReturnType& aRetVal )
- {
- m_retVal = aRetVal;
-- jump( m_self, m_saved, 0 );
-+#if BOOST_VERSION <= 106000
-+ jump( m_callee, m_caller, false );
-+#else
-+ m_caller( this );
-+#endif
- }
-
- /**
-@@ -130,9 +157,9 @@
- *
- * Defines the entry point for the coroutine, if not set in the constructor.
- */
-- void SetEntry( DELEGATE<ReturnType, ArgType> aEntry )
-+ void SetEntry( std::function<ReturnType(ArgType)> aEntry )
- {
-- m_func = aEntry;
-+ m_func = std::move( aEntry );
- }
-
- /* Function Call()
-@@ -143,6 +170,10 @@
- */
- bool Call( ArgType aArgs )
- {
-+ assert( m_callee == NULL );
-+ assert( m_caller == NULL );
-+
-+#if BOOST_VERSION <= 106000
- // fixme: Clean up stack stuff. Add a guard
- m_stack = malloc( c_defaultStackSize );
-
-@@ -151,22 +182,32 @@
-
- // correct the stack size
- m_stackSize -= ( (size_t) m_stack + m_stackSize - (size_t) sp );
--
-- assert( m_self == NULL );
-- assert( m_saved == NULL );
-+#endif
-
- m_args = &aArgs;
--#if BOOST_VERSION >= 105600
-- m_self = new boost::context::fcontext_t();
-- *m_self = boost::context::make_fcontext( sp, m_stackSize, callerStub );
-+
-+#if BOOST_VERSION < 105600
-+ m_callee = boost::context::make_fcontext( sp, m_stackSize, callerStub );
-+#elif BOOST_VERSION <= 106000
-+ m_callee = new context_type( boost::context::make_fcontext( sp, m_stackSize, callerStub ) );
- #else
-- m_self = boost::context::make_fcontext( sp, m_stackSize, callerStub );
-+ m_callee = new context_type( std::allocator_arg_t(),
-+ boost::context::protected_fixedsize_stack( c_defaultStackSize ), &COROUTINE::callerStub );
-+#endif
-+
-+#if BOOST_VERSION <= 106000
-+ m_caller = new context_type();
- #endif
-- m_saved = new boost::context::fcontext_t();
-
- m_running = true;
-+
- // off we go!
-- jump( m_saved, m_self, reinterpret_cast<intptr_t>( this ) );
-+#if BOOST_VERSION <= 106000
-+ jump( m_caller, m_callee, reinterpret_cast<intptr_t>( this ) );
-+#else
-+ auto result = (*m_callee)( this );
-+ *m_callee = std::move( std::get<0>( result ) );
-+#endif
- return m_running;
- }
-
-@@ -179,7 +220,12 @@
- */
- bool Resume()
- {
-- jump( m_saved, m_self, 0 );
-+#if BOOST_VERSION <= 106000
-+ jump( m_caller, m_callee, false );
-+#else
-+ auto result = (*m_callee)( this );
-+ *m_callee = std::move( std::get<0>( result ) );
-+#endif
-
- return m_running;
- }
-@@ -208,61 +254,66 @@
- static const int c_defaultStackSize = 2000000; // fixme: make configurable
-
- /* real entry point of the coroutine */
-+#if BOOST_VERSION <= 106000
- static void callerStub( intptr_t aData )
-+#else
-+ static context_type callerStub( context_type caller, COROUTINE* cor )
-+#endif
- {
- // get pointer to self
-+#if BOOST_VERSION <= 106000
- COROUTINE<ReturnType, ArgType>* cor = reinterpret_cast<COROUTINE<ReturnType, ArgType>*>( aData );
-+#else
-+ cor->m_caller = &caller;
-+#endif
-
- // call the coroutine method
-- cor->m_retVal = cor->m_func( *cor->m_args );
-+ cor->m_retVal = cor->m_func( *( cor->m_args ) );
- cor->m_running = false;
-
- // go back to wherever we came from.
-- jump( cor->m_self, cor->m_saved, 0 ); // reinterpret_cast<intptr_t>( this ));
-+#if BOOST_VERSION <= 106000
-+ jump( cor->m_callee, cor->m_caller, 0 );
-+#else
-+ return caller;
-+#endif
- }
-
- ///> Wrapper for jump_fcontext to assure compatibility between different boost versions
-- static inline intptr_t jump(boost::context::fcontext_t* aOld, boost::context::fcontext_t* aNew,
-+#if BOOST_VERSION <= 106000
-+ static inline intptr_t jump( context_type* aOld, context_type* aNew,
- intptr_t aP, bool aPreserveFPU = true )
- {
--#if BOOST_VERSION >= 105600
-- return boost::context::jump_fcontext( aOld, *aNew, aP, aPreserveFPU );
--#else
-+#if BOOST_VERSION < 105600
- return boost::context::jump_fcontext( aOld, aNew, aP, aPreserveFPU );
-+#else
-+ return boost::context::jump_fcontext( aOld, *aNew, aP, aPreserveFPU );
- #endif
- }
-+#endif
-
-- template <typename T>
-- struct strip_ref
-- {
-- typedef T result;
-- };
-+ std::function<ReturnType(ArgType)> m_func;
-
-- template <typename T>
-- struct strip_ref<T&>
-- {
-- typedef T result;
-- };
-+ bool m_running;
-
-- DELEGATE<ReturnType, ArgType> m_func;
-+#if BOOST_VERSION <= 106000
-+ ///< coroutine stack
-+ void* m_stack;
-+
-+ size_t m_stackSize;
-+#endif
-
- ///< pointer to coroutine entry arguments. Stripped of references
- ///< to avoid compiler errors.
-- typename strip_ref<ArgType>::result* m_args;
-+ typename std::remove_reference<ArgType>::type* m_args;
-+
- ReturnType m_retVal;
-
- ///< saved caller context
-- boost::context::fcontext_t* m_saved;
-+ context_type* m_caller;
-
- ///< saved coroutine context
-- boost::context::fcontext_t* m_self;
--
-- ///< coroutine stack
-- void* m_stack;
--
-- size_t m_stackSize;
--
-- bool m_running;
-+ context_type* m_callee;
- };
-
- #endif
---- a/include/tool/tool_base.h
-+++ b/include/tool/tool_base.h
-@@ -31,7 +32,7 @@
- #include <tool/tool_event.h>
- #include <tool/tool_settings.h>
-
--#include <tool/delegate.h>
-+#include <functional>
-
- class EDA_ITEM;
- class TOOL_MANAGER;
-@@ -53,7 +54,9 @@
-
- /// Unique identifier for tools
- typedef int TOOL_ID;
--typedef DELEGATE<int, const TOOL_EVENT&> TOOL_STATE_FUNC;
-+
-+using TOOL_STATE_FUNC = std::function<int(const TOOL_EVENT&)>;
-+
-
- /**
- * Class TOOL_BASE
---- a/include/tool/tool_interactive.h
-+++ b/include/tool/tool_interactive.h
-@@ -113,7 +114,7 @@
- void TOOL_INTERACTIVE::Go( int (T::* aStateFunc)( const TOOL_EVENT& ),
- const TOOL_EVENT_LIST& aConditions )
- {
-- TOOL_STATE_FUNC sptr( static_cast<T*>( this ), aStateFunc );
-+ TOOL_STATE_FUNC sptr = std::bind( aStateFunc, static_cast<T*>( this ), std::placeholders::_1 );
-
- goInternal( sptr, aConditions );
- }
-
diff --git a/sci-electronics/kicad/files/kicad-cmake-checkcxxsymbolexists.patch b/sci-electronics/kicad/files/kicad-cmake-checkcxxsymbolexists.patch
deleted file mode 100644
index b2a1eeb2cc42..000000000000
--- a/sci-electronics/kicad/files/kicad-cmake-checkcxxsymbolexists.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -Naur kicad-4.0.7.orig/CMakeModules/CheckCXXSymbolExists.cmake kicad-4.0.7/CMakeModules/CheckCXXSymbolExists.cmake
---- kicad-4.0.7.orig/CMakeModules/CheckCXXSymbolExists.cmake 2017-08-28 07:31:31.000000000 -0700
-+++ kicad-4.0.7/CMakeModules/CheckCXXSymbolExists.cmake 1969-12-31 16:00:00.000000000 -0800
-@@ -1,42 +0,0 @@
--# - Check if a symbol exists as a function, variable, or macro in C++
--# CHECK_CXX_SYMBOL_EXISTS(<symbol> <files> <variable>)
--#
--# Check that the <symbol> is available after including given header
--# <files> and store the result in a <variable>. Specify the list
--# of files in one argument as a semicolon-separated list.
--# CHECK_CXX_SYMBOL_EXISTS() can be used to check in C++ files, as opposed
--# to CHECK_SYMBOL_EXISTS(), which works only for C.
--#
--# If the header files define the symbol as a macro it is considered
--# available and assumed to work. If the header files declare the
--# symbol as a function or variable then the symbol must also be
--# available for linking. If the symbol is a type or enum value
--# it will not be recognized (consider using CheckTypeSize or
--# CheckCSourceCompiles).
--#
--# The following variables may be set before calling this macro to
--# modify the way the check is run:
--#
--# CMAKE_REQUIRED_FLAGS = string of compile command line flags
--# CMAKE_REQUIRED_DEFINITIONS = list of macros to define (-DFOO=bar)
--# CMAKE_REQUIRED_INCLUDES = list of include directories
--# CMAKE_REQUIRED_LIBRARIES = list of libraries to link
--
--#=============================================================================
--# Copyright 2003-2011 Kitware, Inc.
--#
--# Distributed under the OSI-approved BSD License (the "License");
--# see accompanying file Copyright.txt for details.
--#
--# This software is distributed WITHOUT ANY WARRANTY; without even the
--# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
--# See the License for more information.
--#=============================================================================
--# (To distribute this file outside of CMake, substitute the full
--# License text for the above reference.)
--
--include(CheckSymbolExists)
--
--macro(CHECK_CXX_SYMBOL_EXISTS SYMBOL FILES VARIABLE)
-- _CHECK_SYMBOL_EXISTS("${CMAKE_BINARY_DIR}${CMAKE_FILES_DIRECTORY}/CMakeTmp/CheckSymbolExists.cxx" "${SYMBOL}" "${FILES}" "${VARIABLE}" )
--endmacro()
diff --git a/sci-electronics/kicad/files/kicad-footprints-cmakelists.txt b/sci-electronics/kicad/files/kicad-footprints-cmakelists.txt
deleted file mode 100644
index d024485befd0..000000000000
--- a/sci-electronics/kicad/files/kicad-footprints-cmakelists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
-project( kicad-footprints )
-
-cmake_minimum_required( VERSION 2.6.1 FATAL_ERROR )
-
-file(GLOB footprint_dirs "*.pretty")
-
-# Everything without leading / is relative to CMAKE_INSTALL_PREFIX.
-set( KICAD_DATA share/kicad
- CACHE PATH "Location of KiCad data files." )
-set( KICAD_MODULES ${KICAD_DATA}/modules )
-
-mark_as_advanced( KICAD_DATA KICAD_MODULES )
-
-install(DIRECTORY ${footprint_dirs}
- DESTINATION ${KICAD_MODULES}
- COMPONENT resources)
diff --git a/sci-electronics/kicad/kicad-4.0.7-r1.ebuild b/sci-electronics/kicad/kicad-4.0.7-r1.ebuild
deleted file mode 100644
index a85b949bc42d..000000000000
--- a/sci-electronics/kicad/kicad-4.0.7-r1.ebuild
+++ /dev/null
@@ -1,198 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-WX_GTK_VER="3.0"
-
-inherit check-reqs cmake-utils flag-o-matic gnome2-utils python-single-r1 wxwidgets vcs-snapshot versionator xdg
-
-SERIES=$(get_version_component_range 1-2)
-
-DESCRIPTION="Electronic Schematic and PCB design tools."
-HOMEPAGE="http://www.kicad-pcb.org"
-SRC_URI="https://launchpad.net/${PN}/${SERIES}/${PV}/+download/${P}.tar.xz
- !minimal? (
- http://downloads.kicad-pcb.org/libraries/${PN}-footprints-${PV}.tar.gz
- http://downloads.kicad-pcb.org/libraries/kicad-library-${PV}.tar.gz
- )
- i18n? ( https://github.com/KiCad/${PN}-i18n/archive/${PV}.tar.gz -> ${P}-i18n.tar.gz )"
-
-LICENSE="GPL-2+ GPL-3+ Boost-1.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="debug doc examples github i18n libressl minimal +python"
-LANGS="bg ca cs de el es fi fr hu it ja ko nl pl pt ru sk sl sv zh-CN"
-for lang in ${LANGS} ; do
- IUSE="${IUSE} l10n_${lang}"
-done
-unset lang
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND=">=x11-libs/wxGTK-3.0.2:${WX_GTK_VER}[X,opengl]
- $(python_gen_cond_dep "
- python? (
- dev-python/wxpython:${WX_GTK_VER}[opengl,\${PYTHON_MULTI_USEDEP}]
- ${PYTHON_DEPS}
- )
- >=dev-libs/boost-1.61:=[context,nls,threads,python?,\${PYTHON_MULTI_USEDEP}]
- ")
- github? (
- libressl? ( dev-libs/libressl:0= )
- !libressl? ( dev-libs/openssl:0= )
- )
- media-libs/glew:0=
- media-libs/freeglut
- media-libs/mesa[X(+)]
- sys-libs/zlib
- x11-libs/cairo"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- i18n? ( virtual/libintl )
- python? ( dev-lang/swig:0 )"
-RDEPEND="${COMMON_DEPEND}
- sci-electronics/electronics-menu"
-
-pkg_pretend() {
- CHECKREQS_DISK_BUILD="8G"
- check-reqs_pkg_pretend
-}
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- setup-wxwidgets
- CHECKREQS_DISK_BUILD="8G"
- check-reqs_pkg_setup
-}
-
-src_prepare() {
- xdg_src_prepare
- cmake-utils_src_prepare
-
- # Patch to work with >=boost 1.61
- eapply "${FILESDIR}/${PN}-boost-1.61.patch"
- # Patch to work with >=cmake 3.11
- eapply "${FILESDIR}/${PN}-cmake-checkcxxsymbolexists.patch"
-
- # Remove cvpcb desktop file as it does nothing
- rm "resources/linux/mime/applications/cvpcb.desktop" || die
-
- # Handle optional minimal install.
- if use minimal; then
- # remove templates as they are not needed to run binaries
- sed -e '/add_subdirectory( template )/d' -i CMakeLists.txt || die
- else
- # create a link to the parts library in the main project folder
- ln -s "${WORKDIR}/kicad-library-${PV}" "${S}/${PN}-library" || die
- # create a link to the footprints library and add cmake build rule for it
- ln -s "${WORKDIR}/${PN}-footprints-${PV}" "${S}/${PN}-footprints" || die
- cp "${FILESDIR}/${PN}-footprints-cmakelists.txt" "${WORKDIR}/${PN}-footprints-${PV}/CMakeLists.txt" || die
- # add the libraries directory to cmake as a subproject to build
- sed "/add_subdirectory( bitmaps_png )/a add_subdirectory( ${PN}-library )" -i CMakeLists.txt || die
- # add the footprints directory to cmake as a subproject to build
- sed "/add_subdirectory( ${PN}-library )/a add_subdirectory( ${PN}-footprints )" -i CMakeLists.txt || die
- # remove duplicate uninstall directions for the library module
- sed '/make uninstall/,/# /d' -i ${PN}-library/CMakeLists.txt || die
- fi
-
- # Add internationalization for the GUI
- if use i18n; then
- # create a link to the translations library in the main project folder
- ln -s "${WORKDIR}/${P}-i18n" "${S}/${PN}-i18n" || die
- # Remove unused languages. Project generates only languages specified in the
- # file in LINGUAS in the subproject folder. By default all languages are added
- # so we sed out the unused ones based on the user l10n_* settings.
- local lang
- for lang in ${LANGS}; do
- if ! use l10n_${lang}; then
- lang="${lang//-/_}" # Needed to turn zh-CN to zh_CN as KiCad does not follow l10n standard here
- sed "/${lang}/d" -i ${PN}-i18n/LINGUAS || die
- fi
- done
- # cmakelists does not respect our build dir variables, so make it point to the right location
- sed "s|\${CMAKE_BINARY_DIR}|${WORKDIR}/${P}_build|g" -i ${PN}-i18n/CMakeLists.txt || die
- # we also make from the master project so the source dir is understood incorretly, replace that too
- sed "s|\${CMAKE_SOURCE_DIR}/\${LANG}|\${CMAKE_SOURCE_DIR}/${PN}-i18n/\${LANG}|g" -i ${PN}-i18n/CMakeLists.txt || die
- # add the translations directory to cmake as a subproject to build
- sed "/add_subdirectory( bitmaps_png )/a add_subdirectory( ${PN}-i18n )" -i CMakeLists.txt || die
- # remove duplicate uninstall directions for the translation module
- sed '/make uninstall/,$d' -i ${PN}-i18n/CMakeLists.txt || die
- fi
-
- # Install examples if requested
- use examples || sed -e '/add_subdirectory( demos )/d' -i CMakeLists.txt || die
-
- # Add important missing doc files
- sed -e 's/INSTALL.txt/AUTHORS.txt CHANGELOG.txt README.txt TODO.txt/' -i CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DKICAD_DOCS="/usr/share/doc/${PF}"
- -DKICAD_SKIP_BOOST=ON
- -DBUILD_GITHUB_PLUGIN="$(usex github)"
- -DKICAD_SCRIPTING="$(usex python)"
- -DKICAD_SCRIPTING_MODULES="$(usex python)"
- -DKICAD_SCRIPTING_WXPYTHON="$(usex python)"
- -DKICAD_I18N_UNIX_STRICT_PATH="$(usex i18n)"
- -DCMAKE_CXX_FLAGS="-std=c++11"
- )
- use python && mycmakeargs+=(
- -DwxUSE_UNICODE=ON
- -DPYTHON_DEST="$(python_get_sitedir)"
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
- -DPYTHON_LIBRARY="$(python_get_library_path)"
- )
- if use debug; then
- append-cxxflags "-DDEBUG"
- append-cflags "-DDEBUG"
- fi
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use doc; then
- doxygen Doxyfile || die
- fi
-}
-
-src_install() {
- cmake-utils_src_install
- use python && python_optimize
- if use doc ; then
- dodoc uncrustify.cfg
- cd Documentation || die
- dodoc -r GUI_Translation_HOWTO.pdf guidelines/UIpolicies.txt doxygen/.
- fi
-}
-
-pkg_preinst() {
- xdg_pkg_preinst
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_icon_cache_update
-
- if use minimal ; then
- ewarn "If the schematic and/or board editors complain about missing libraries when you"
- ewarn "open old projects, you will have to take one or more of the following actions :"
- ewarn "- Install the missing libraries manually."
- ewarn "- Remove the libraries from the 'Libs and Dir' preferences."
- ewarn "- Fix the libraries' locations in the 'Libs and Dir' preferences."
- ewarn "- Emerge ${PN} without the 'minimal' USE flag."
- fi
- elog ""
- elog "You may want to emerge media-gfx/wings if you want to create 3D models of components."
- elog "For help and extended documentation emerge app-doc/kicad-doc."
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_icon_cache_update
-}
diff --git a/sci-electronics/kicad/metadata.xml b/sci-electronics/kicad/metadata.xml
index 6eff0d23cafb..0892cbd7d4b8 100644
--- a/sci-electronics/kicad/metadata.xml
+++ b/sci-electronics/kicad/metadata.xml
@@ -11,8 +11,6 @@
</maintainer>
<use>
<flag name="github">Add github support into PCB editor</flag>
- <flag name="i18n">Allow GUI internationalization through l10n_* use flags</flag>
- <flag name="minimal">Build only binaries without parts library and examples</flag>
<flag name="ngspice">Enable circuit simulation</flag>
<flag name="occ">Enable viewing 3D rendering of designs via opencascade</flag>
<flag name="oce">Enable viewing 3D rendering of designs via OCE</flag>