summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-24 19:08:44 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-24 19:08:44 -0500
commit05871c29c9c8551d66fd733b7cd9b5ab22a1d378 (patch)
tree80923897d78644dd19a15bdfed54be2d7e90c4c2
parentdev-python/ipdb: adding arm (diff)
downloadgentoo-05871c29c9c8551d66fd733b7cd9b5ab22a1d378.tar.gz
gentoo-05871c29c9c8551d66fd733b7cd9b5ab22a1d378.tar.bz2
gentoo-05871c29c9c8551d66fd733b7cd9b5ab22a1d378.zip
app-crypt/certbot: bup to 0.17.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-0.17.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index a8cfdba45264..8a5e0817e457 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1 +1,2 @@
DIST certbot-0.15.0.tar.gz 942788 SHA256 87d306b1c013b472b8f548b38ccc476c125816435bb3b99e932fed09ac777296 SHA512 e884b34985a1128ce94d6b2be77af6ee86ded8b870e066f3f4bc22f78501f3f0a51060edcf75a11cd31dd525388adb8ccc4e2da0068b5b75be131d0fb0ca6844 WHIRLPOOL 01b172e8c7ac5d3678ee608b36d93f23943bf17f1e9c593cc1af3febcf0549b03961e69e537f099643dd9ee268497f76c2c18d8fa7a1d45753bc50e670375317
+DIST certbot-0.17.0.tar.gz 1036099 SHA256 ed4334dce166bf38ecc7218449efda3798d62c7e2934a71702c0dc3d78eccdd1 SHA512 57fa830d19173eacdbb17242a3c446d9414f02e09fab6ccd41c82b15156bc103ec358ff3d515e94881fcf6438f6acfe449eee9bb3108df41f7b8f2395500b549 WHIRLPOOL cbfffc3866ffed3e0c702ac686768e879c7f1306a62dc050aab05e5a207b4f77a4acae9ca8f3ce973a6691d98838a488ab6335aa0692dd2b28a99c8aecff232d
diff --git a/app-crypt/certbot/certbot-0.17.0.ebuild b/app-crypt/certbot/certbot-0.17.0.ebuild
new file mode 100644
index 000000000000..4075ad538f38
--- /dev/null
+++ b/app-crypt/certbot/certbot-0.17.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.2[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ >=dev-python/astroid-1.3.5[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ipdb[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.4.2[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests -v ${PN} || die
+}