summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-02 16:31:38 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-02 16:33:14 -0500
commit0592d0ded682e351a59b566d5bf024bc50377beb (patch)
treec7c55a2be3eb7e966f8cc2db3dd71ac55a3a50b3
parentgames-board/pokerth: remove deprecated games eclass (diff)
downloadgentoo-0592d0ded682e351a59b566d5bf024bc50377beb.tar.gz
gentoo-0592d0ded682e351a59b566d5bf024bc50377beb.tar.bz2
gentoo-0592d0ded682e351a59b566d5bf024bc50377beb.zip
games-board/pioneers: remove deprecated gnome-games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
-rw-r--r--games-board/pioneers/pioneers-15.3-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-board/pioneers/pioneers-15.3-r1.ebuild b/games-board/pioneers/pioneers-15.3-r1.ebuild
new file mode 100644
index 000000000000..3e9eba15d344
--- /dev/null
+++ b/games-board/pioneers/pioneers-15.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://pio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pio/${P}.tar.gz"
+
+LICENSE="GPL-2 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated help nls"
+
+# dev-util/gob only for autoreconf
+RDEPEND=">=dev-libs/glib-2.26:2
+ !dedicated? (
+ >=x11-libs/gtk+-3.4:3
+ >=x11-libs/libnotify-0.7.4
+ help? (
+ app-text/rarian
+ >=gnome-base/libgnome-2.10
+ )
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/gob:2
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable nls) \
+ $(use_enable help) \
+ --includedir=/usr/include \
+ $(use_with !dedicated gtk)
+}
+
+src_install() {
+ DOCS='AUTHORS ChangeLog README TODO NEWS' \
+ gnome2_src_install scrollkeeper_localstate_dir="${ED%/}"/var/lib/scrollkeeper/
+}