summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-24 21:41:32 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-24 21:41:50 +0100
commit075dd15350df70a121a25756609f1409905d0139 (patch)
tree46d70ef04ab6932c90c11cfc43db32103661736b
parentvirtual/jdk: Add the upcoming icedtea(-bin):8 to 1.8 (diff)
downloadgentoo-075dd15350df70a121a25756609f1409905d0139.tar.gz
gentoo-075dd15350df70a121a25756609f1409905d0139.tar.bz2
gentoo-075dd15350df70a121a25756609f1409905d0139.zip
sys-power/cpudyn: add -std=gnu89 to CFLAGS to restore pre-GCC5 semantics
Gentoo-Bug: 570082 * EAPI=6 * Make patch -p1 compatible Package-Manager: portage-2.2.27
-rw-r--r--sys-power/cpudyn/cpudyn-1.0.1-r1.ebuild48
-rw-r--r--sys-power/cpudyn/files/cpudyn-0.99.0-init_conf_updates.patch4
2 files changed, 50 insertions, 2 deletions
diff --git a/sys-power/cpudyn/cpudyn-1.0.1-r1.ebuild b/sys-power/cpudyn/cpudyn-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..c3dd5eec3f66
--- /dev/null
+++ b/sys-power/cpudyn/cpudyn-1.0.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A daemon to control laptop power consumption via cpufreq and disk standby"
+HOMEPAGE="http://freecode.com/projects/cpudyn/"
+SRC_URI="http://mnm.uib.es/~gallir/${PN}/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.99.0-init_conf_updates.patch"
+)
+
+src_prepare() {
+ # fix #570082 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ default
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" cpudynd
+}
+
+src_install() {
+ dosbin cpudynd
+
+ doman cpudynd.8
+ dodoc INSTALL README VERSION changelog
+ dodoc *.html
+
+ newinitd "${FILESDIR}"/cpudyn.init cpudyn
+ newconfd debian/cpudyn.conf cpudyn
+}
+
+pkg_postinst() {
+ einfo "Configuration file is /etc/conf.d/cpudyn."
+}
diff --git a/sys-power/cpudyn/files/cpudyn-0.99.0-init_conf_updates.patch b/sys-power/cpudyn/files/cpudyn-0.99.0-init_conf_updates.patch
index fcfb55294d33..f6aca0b7a9f8 100644
--- a/sys-power/cpudyn/files/cpudyn-0.99.0-init_conf_updates.patch
+++ b/sys-power/cpudyn/files/cpudyn-0.99.0-init_conf_updates.patch
@@ -1,5 +1,5 @@
---- gentoo/cpudyn.conf.orig 2004-01-08 17:20:39.575230665 +0100
-+++ gentoo/cpudyn.conf 2004-01-08 17:20:37.450290151 +0100
+--- cpudyn/debian/cpudyn.conf.orig 2004-01-08 17:20:39.575230665 +0100
++++ cpudyn/debian/cpudyn.conf 2004-01-08 17:20:37.450290151 +0100
@@ -32,6 +32,12 @@
THROTTLING_LOW=7