summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-10-14 15:37:55 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-14 20:20:40 +0200
commit0831882bdc47dcf011f36382017dffa40bcb8390 (patch)
treeb847cf58bf1212444b4815d0913c098169e66243
parentsys-cluster/ceph: Enable the tcmalloc USE flag by default (diff)
downloadgentoo-0831882bdc47dcf011f36382017dffa40bcb8390.tar.gz
gentoo-0831882bdc47dcf011f36382017dffa40bcb8390.tar.bz2
gentoo-0831882bdc47dcf011f36382017dffa40bcb8390.zip
sci-calculators/calcoo: EAPI bump 4 -> 6
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2556 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-calculators/calcoo/calcoo-1.3.18-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-calculators/calcoo/calcoo-1.3.18-r1.ebuild b/sci-calculators/calcoo/calcoo-1.3.18-r1.ebuild
new file mode 100644
index 000000000000..0f7eee6c9680
--- /dev/null
+++ b/sci-calculators/calcoo/calcoo-1.3.18-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="Scientific calculator designed to provide maximum usability"
+HOMEPAGE="http://calcoo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gold.patch )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-gtktest
+}
+
+src_install() {
+ default
+ newicon src/pixmaps/main.xpm ${PN}.xpm
+ make_desktop_entry ${PN} Calcoo ${PN} "Education;Math"
+}