summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2018-06-02 14:21:16 +0200
committerAaron Bauman <bman@gentoo.org>2018-06-02 22:13:32 -0400
commit0f887eb0d965989837dcc5d14b60027f34ba6fcf (patch)
treed27064c3da058b53beff0d704b478be34595a46a
parentapp-shells/yash: fix HOMEPAGE (diff)
downloadgentoo-0f887eb0d965989837dcc5d14b60027f34ba6fcf.tar.gz
gentoo-0f887eb0d965989837dcc5d14b60027f34ba6fcf.tar.bz2
gentoo-0f887eb0d965989837dcc5d14b60027f34ba6fcf.zip
dev-python/tempora: bump to 1.11, EAPI=7, cosmetic fixes
This new version requires dev-python/freezegun to run tests. Package-Manager: Portage-2.3.38, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8691
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/tempora-1.11.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index 2a8a8ed86e2d..00666673b1a4 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1,3 +1,4 @@
+DIST tempora-1.11.tar.gz 14750 BLAKE2B d8e448f9cf363a49b30bc016faeaccf1e724c8887d179570b4e46e2eb8d7eaccf7837ffc43e02e956869caa22ac037507e2b17c11540fdb7e6610fd7607780b6 SHA512 cda47613cabefabb0c52e2f89f31b405a3b3f17c531a0b890a9ccfd3a3fcd5bc5bec19881ce726972ff61811654e8b5ec8048c9ebad6e87d72d7d98bfa4daeab
DIST tempora-1.6.1.tar.gz 11423 BLAKE2B d549581d92d9205eaa9495cba251891a7c93859abf1d402b2e0b7f344f882acbe11578fd66a0f604dbff3458108f04582ce527148f0fa1b2d683872c17d32015 SHA512 9baf9162e304e59ae0a427a7a27d1fc66b0d4b98e016490317832ba2e7acec520ef2baeebeb26f7984ba7ace82413d15b96baef7dbdfcfdc94e29e7179769a01
DIST tempora-1.7.tar.gz 11645 BLAKE2B d354fb863a8d30bd9e603ad942d7c7f61a70c24e7f1fe94fffd59982431190e2807c2dc577ff83eb90ffc5fd2b2f8415965de1d77e4dca0dd02291733bfbb97c SHA512 2420e32a9b8c990609d8f09225004e0b1c445cad1fe3c3c74625cb8317b552469acf2d3b28aa56633a87260a93c77d73b02178cb662016c514bc740aa01399e5
DIST tempora-1.9.tar.gz 12469 BLAKE2B da18fc066cb9cf7ee0fa7eefb39ea2ac941760144c7efdea66a05780ced43d574757665dfad6088f98c135e7b14874aef0c8243ab338fcbaa5a515ec27507f52 SHA512 cb049675d7196738debca3dc0ddd8c5e72d0468bd1a853f77378cc5564b100cd94d23c63d7b06c6bed2827365d904a1582cf9d497618493b795600b6d476b91f
diff --git a/dev-python/tempora/tempora-1.11.ebuild b/dev-python/tempora/tempora-1.11.ebuild
new file mode 100644
index 000000000000..f194bb50ce89
--- /dev/null
+++ b/dev-python/tempora/tempora-1.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+# The calc-prorate binary used to be part of jaraco.utils
+DEPEND="
+ !<=dev-python/jaraco-utils-10.0.2
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+ >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # Override pytest options to skip flake8
+ PYTHONPATH=. py.test --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}