summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2019-04-04 14:29:41 +0200
committerAndrey Grozin <grozin@gentoo.org>2019-04-04 14:30:10 +0200
commit10c376829e9db8a9f6ea971dfb44e9573570b325 (patch)
treeeed8f1165affd8a609d03adbc8b227170834d217
parentsys-kernel/gentoo-sources: Linux 5.0.6 and removal of redudant patch (diff)
downloadgentoo-10c376829e9db8a9f6ea971dfb44e9573570b325.tar.gz
gentoo-10c376829e9db8a9f6ea971dfb44e9573570b325.tar.bz2
gentoo-10c376829e9db8a9f6ea971dfb44e9573570b325.zip
dev-python/bpython: cleaning old
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--dev-python/bpython/Manifest2
-rw-r--r--dev-python/bpython/bpython-0.16-r1.ebuild55
-rw-r--r--dev-python/bpython/bpython-0.16.ebuild55
-rw-r--r--dev-python/bpython/bpython-0.17.ebuild55
4 files changed, 0 insertions, 167 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
index 55bb645faa62..7746ce02c60b 100644
--- a/dev-python/bpython/Manifest
+++ b/dev-python/bpython/Manifest
@@ -1,3 +1 @@
-DIST bpython-0.16.tar.gz 201898 BLAKE2B 907f6a506d2b52db01e7b84c615574a7daad36f630646a345c963e432cc394330339390b6afc2585845b19d6c00d9c0b95e06b9d3b0fe85fe20daad3f5cf208a SHA512 1173d720aa679e4a6079c7febd36abbffa901604c99c6d1ce1e940a8fbcf8a4ba7bc526de0ef5290e3859a4384d1cd5cbef62fd9f056ddcb545b64d69d103a5b
DIST bpython-0.17.1.tar.gz 213638 BLAKE2B 42530a38f8cf714a0415957a46374b83ad14dfab89a76317507763c2f83b3dbc8f71c7cc967ec353fabd38b6631130d34df99c0d53f3728fa2390d4a6f64b25d SHA512 5b5e861646df90510db75520dff9533b71501d35b7af1d152adf2c929b171fa6a2b1c0a6b7eda0311f9315703db161c6a78698a6cd434e5321464d6d1c033e4e
-DIST bpython-0.17.tar.gz 214230 BLAKE2B dc26de037eb5698c04afb74472fe9483e1398f4f40b7da21520f2e7e2ba6e510bcbf200938d520d95b976a6fbeb31af7b1b1f828a022835edbe40d381c82797d SHA512 17c25f4ed69eb7cff27ba0a488434623a7105c60bbf1e6f608c91babf240741ab7a7097ad347f897cd5f39f2fedb944fd69d8dbfbc66da6b910e1a14ace6fd1f
diff --git a/dev-python/bpython/bpython-0.16-r1.ebuild b/dev-python/bpython/bpython-0.16-r1.ebuild
deleted file mode 100644
index 70407a76fccd..000000000000
--- a/dev-python/bpython/bpython-0.16-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
-HOMEPAGE="https://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.org/project/bpython/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/curtsies-0.2.11[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- dev-python/jedi[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.5[${PYTHON_USEDEP}]
- dev-python/urwid[${PYTHON_USEDEP}]
- dev-python/watchdog[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-DOCS=( AUTHORS CHANGELOG sample.theme light.theme )
-
-# Req'd for clean build by each impl
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- if use doc; then
- sphinx-build -b html -c doc/sphinx/source/ \
- doc/sphinx/source/ doc/sphinx/source/html || die "docs build failed"
- fi
-}
-
-python_test() {
- pushd build/lib > /dev/null
- "${PYTHON}" -m unittest discover || die
- popd > /dev/null
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/sphinx/source/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/bpython/bpython-0.16.ebuild b/dev-python/bpython/bpython-0.16.ebuild
deleted file mode 100644
index 35036333262e..000000000000
--- a/dev-python/bpython/bpython-0.16.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
-HOMEPAGE="https://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.org/project/bpython/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/curtsies-0.2.10[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- dev-python/jedi[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.5[${PYTHON_USEDEP}]
- dev-python/urwid[${PYTHON_USEDEP}]
- dev-python/watchdog[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-DOCS=( AUTHORS CHANGELOG sample.theme light.theme )
-
-# Req'd for clean build by each impl
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- if use doc; then
- sphinx-build -b html -c doc/sphinx/source/ \
- doc/sphinx/source/ doc/sphinx/source/html || die "docs build failed"
- fi
-}
-
-python_test() {
- pushd build/lib > /dev/null
- "${PYTHON}" -m unittest discover || die
- popd > /dev/null
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/sphinx/source/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/bpython/bpython-0.17.ebuild b/dev-python/bpython/bpython-0.17.ebuild
deleted file mode 100644
index 5c37145681cb..000000000000
--- a/dev-python/bpython/bpython-0.17.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
-HOMEPAGE="https://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.org/project/bpython/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/curtsies-0.2.11[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- dev-python/jedi[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.5[${PYTHON_USEDEP}]
- dev-python/urwid[${PYTHON_USEDEP}]
- dev-python/watchdog[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-DOCS=( AUTHORS CHANGELOG sample.theme light.theme )
-
-# Req'd for clean build by each impl
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- if use doc; then
- sphinx-build -b html -c doc/sphinx/source/ \
- doc/sphinx/source/ doc/sphinx/source/html || die "docs build failed"
- fi
-}
-
-python_test() {
- pushd build/lib > /dev/null
- "${PYTHON}" -m unittest discover || die
- popd > /dev/null
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/sphinx/source/html/. )
- distutils-r1_python_install_all
-}