summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-03-06 11:12:25 -0800
committerMatt Turner <mattst88@gentoo.org>2018-03-06 11:13:08 -0800
commit13028dce42492cab81d0216587272381f4c897df (patch)
tree5a20399fb73fd2e2a5900fd22d9f74a34209e9eb
parentsys-apps/portage-2.3.24-r1: re-add ~arm64 (diff)
downloadgentoo-13028dce42492cab81d0216587272381f4c897df.tar.gz
gentoo-13028dce42492cab81d0216587272381f4c897df.tar.bz2
gentoo-13028dce42492cab81d0216587272381f4c897df.zip
x11-drivers/xf86-video-ati: Add live ebuild
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
new file mode 100644
index 000000000000..3bb9e4ef6269
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_DRI=always
+inherit linux-info xorg-2
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="https://www.x.org/wiki/ati/"
+
+IUSE="+glamor udev"
+
+RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_radeon]
+ >=x11-libs/libpciaccess-0.8.0
+ glamor? ( x11-base/xorg-server[glamor] )
+ udev? ( virtual/udev )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+ else
+ CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+ fi
+ fi
+ check_extra_config
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable glamor)
+ $(use_enable udev)
+ )
+ xorg-2_src_configure
+}