summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-12 05:32:12 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-12 09:18:43 +1300
commit13d680e6377576e2058b1b71301075a496f7dfbd (patch)
treed9310aa463a8d5fdd82132f95bdfd142bf8b03ad
parentperl-core/Scalar-List-Utils: Add 1.460.0 (diff)
downloadgentoo-13d680e6377576e2058b1b71301075a496f7dfbd.tar.gz
gentoo-13d680e6377576e2058b1b71301075a496f7dfbd.tar.bz2
gentoo-13d680e6377576e2058b1b71301075a496f7dfbd.zip
perl-core/Test-Simple: Bump to 1.302.62
Upstream: - fix setting "hub" while getting context - fix "skip_all" in require in intercept - make ctx->send_event detect termination events - allow "#" and "\n" in "ok" names - fix "ok" ending in '\' - Win32 Color support in Test::Builder::Tester - v-strings comparison supported in is_deeply - streamed subtests in buffered subtests are now buffered subtests. - Mask warning comparing with $@ in Test2::API::Context - Formatters now have terminate() and finalize() methods - Removed warning when using a non-TAP formatter under Test::Builder Package-Manager: portage-2.3.2
-rw-r--r--perl-core/Test-Simple/Manifest1
-rw-r--r--perl-core/Test-Simple/Test-Simple-1.302.62.ebuild46
-rw-r--r--virtual/perl-Test-Simple/perl-Test-Simple-1.302.62.ebuild20
3 files changed, 67 insertions, 0 deletions
diff --git a/perl-core/Test-Simple/Manifest b/perl-core/Test-Simple/Manifest
index 3b969f5892de..c71e1bd4c226 100644
--- a/perl-core/Test-Simple/Manifest
+++ b/perl-core/Test-Simple/Manifest
@@ -1,2 +1,3 @@
DIST Test-Simple-1.001014.tar.gz 127212 SHA256 55a414ce89eb7a5e9e84186f286b002054f10ae8ef4f8f2d61bb710e7549f16b SHA512 0aa0b4d78c0243480df0e7f9b28d69b6bbf1b26bd49a91827c2d61595319840f7178f179555a60ef28d49d3f50679aade4f6d8138e9ae1bd0113a3d6c66d89c2 WHIRLPOOL 554c292cc05e31c0f82094ff23a556d46526388f9b51b7c3367fb1c34ed692c03b03b1be46f75f6b9186bcd52b3a4e613064252c8f6234ef5711da2a29bec3a7
DIST Test-Simple-1.302049.tar.gz 242269 SHA256 241b9ce01ad1c16f61d8f32211ac8e8cdac4d50ec44b0fa9b795f0b20da4a5f0 SHA512 1ca909c1bfaec7742635e4df2846e6bf767eb6be9593d0553836dc3a580bca76c60c7b4232e2334179236b10bf42354fe93001dbf29bf8a280c39d96fd04b18a WHIRLPOOL 6c6a350c0fa2dd0ce3f261bec6b106f0d247acdf4afac12006e873488e7405988a31b38be1d75ac5763b562fa1c84a2b0418eff7c0693f86f87be9e0ce88c602
+DIST Test-Simple-1.302062.tar.gz 247549 SHA256 6729060d4ab12e2db3a3c6d6376ee6a9fb77c0ba0308b66919365a1e8bf156ea SHA512 8c221ec4ee33da68191df6c8e13f82f90d694a1d87e2406a4af500b70bd87e8b58093735ca71c63c6cb569673e088d9f558bf7155c1f5e885eada354c090d3ff WHIRLPOOL 970f61e718a94b29c02e2b8315326a42b1bb9fae367e12f3e11f1b5b9a4f112dab5d38a68b8e3404e3dce07d14b7c86f074b3a77110b71afdaffb73261e8afe2
diff --git a/perl-core/Test-Simple/Test-Simple-1.302.62.ebuild b/perl-core/Test-Simple/Test-Simple-1.302.62.ebuild
new file mode 100644
index 000000000000..666dec4b3598
--- /dev/null
+++ b/perl-core/Test-Simple/Test-Simple-1.302.62.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=EXODIST
+DIST_VERSION=1.302062
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Basic utilities for writing tests"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ !<dev-perl/Test-Tester-0.114.0
+ !<dev-perl/Test-use-ok-0.160.0
+ !<dev-perl/Log-Dispatch-Config-TestLog-0.20.0
+ !<dev-perl/Net-BitTorrent-0.52.0
+ !<dev-perl/Test-Able-0.110.0
+ !<dev-perl/Test-Aggregate-0.373.0
+ !<dev-perl/Test-Alien-0.40.0
+ !<dev-perl/Test-Builder-Clutch-0.70.0
+ !<dev-perl/Test-Clustericious-Cluster-0.300.0
+ !<dev-perl/Test-Dist-VersionSync-1.1.4
+ !<dev-perl/Test-Exception-0.420.0
+ !<dev-perl/Test-Flatten-0.110.0
+ !<dev-perl/Test-Group-0.200.0
+ !<dev-perl/Test-Modern-0.12.0
+ !<dev-perl/Test-More-Prefix-0.5.0
+ !<dev-perl/Test-ParallelSubtest-0.50.0
+ !<dev-perl/Test-Pretty-0.320.0
+ !<dev-perl/Test-SharedFork-0.340.0
+ !<dev-perl/Test-Wrapper-0.3.0
+ !<dev-perl/Test-UseAllModules-0.140.0
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ >=virtual/perl-Scalar-List-Utils-1.130.0
+ virtual/perl-Storable
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
diff --git a/virtual/perl-Test-Simple/perl-Test-Simple-1.302.62.ebuild b/virtual/perl-Test-Simple/perl-Test-Simple-1.302.62.ebuild
new file mode 100644
index 000000000000..7eab2a509e88
--- /dev/null
+++ b/virtual/perl-Test-Simple/perl-Test-Simple-1.302.62.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Virtual for ${PN#perl-}"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ ~perl-core/${PN#perl-}-${PV}
+ !<dev-perl/Test-Tester-0.114.0
+ !<dev-perl/Test-use-ok-0.160.0
+"