summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-11 01:35:00 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-11 01:48:19 -0600
commit15b382bd8748651965689a498a3e79191471fe8e (patch)
treeee775a9cf67123f262d5b903067e41e52c45d7e5
parentsys-fs/fuse-common: fix install on systems without udev (diff)
downloadgentoo-15b382bd8748651965689a498a3e79191471fe8e.tar.gz
gentoo-15b382bd8748651965689a498a3e79191471fe8e.tar.bz2
gentoo-15b382bd8748651965689a498a3e79191471fe8e.zip
net-news/newsboat: use bundled catch headers to simplify/fix tests
Closes: https://bugs.gentoo.org/672802 Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--net-news/newsboat/newsboat-2.12.ebuild19
-rw-r--r--net-news/newsboat/newsboat-9999.ebuild19
2 files changed, 6 insertions, 32 deletions
diff --git a/net-news/newsboat/newsboat-2.12.ebuild b/net-news/newsboat/newsboat-2.12.ebuild
index c7cc7bf5863d..ee6c86f08943 100644
--- a/net-news/newsboat/newsboat-2.12.ebuild
+++ b/net-news/newsboat/newsboat-2.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,7 @@ HOMEPAGE="https://newsboat.org/ https://github.com/newsboat/newsboat"
LICENSE="MIT"
SLOT="0"
-IUSE="test"
+IUSE=""
RDEPEND="
>=dev-db/sqlite-3.5:3
@@ -32,36 +32,23 @@ DEPEND="${RDEPEND}
app-text/asciidoc
virtual/pkgconfig
sys-devel/gettext
- test? ( >=dev-cpp/catch-2 )
"
PATCHES=(
"${FILESDIR}"/${PN}-2.11-flags.patch
)
-src_prepare() {
- default
-
- # use system catch
- sed -i 's#"3rd-party/catch.hpp"#<catch/catch.hpp>#' test/*.{cpp,h} || die
- rm 3rd-party/catch.hpp || die
-}
-
src_configure() {
./config.sh || die
}
src_compile() {
- # update object build deps to use system catch
- echo > mk/mk.deps || die
- emake depslist
-
emake prefix="/usr" CXX="$(tc-getCXX)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
}
src_test() {
# tests require UTF-8 locale
- emake test
+ emake CXX="$(tc-getCXX)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" test
# Tests fail if in ${S} rather than in ${S}/test
cd "${S}"/test || die
./test || die
diff --git a/net-news/newsboat/newsboat-9999.ebuild b/net-news/newsboat/newsboat-9999.ebuild
index c7cc7bf5863d..ee6c86f08943 100644
--- a/net-news/newsboat/newsboat-9999.ebuild
+++ b/net-news/newsboat/newsboat-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,7 @@ HOMEPAGE="https://newsboat.org/ https://github.com/newsboat/newsboat"
LICENSE="MIT"
SLOT="0"
-IUSE="test"
+IUSE=""
RDEPEND="
>=dev-db/sqlite-3.5:3
@@ -32,36 +32,23 @@ DEPEND="${RDEPEND}
app-text/asciidoc
virtual/pkgconfig
sys-devel/gettext
- test? ( >=dev-cpp/catch-2 )
"
PATCHES=(
"${FILESDIR}"/${PN}-2.11-flags.patch
)
-src_prepare() {
- default
-
- # use system catch
- sed -i 's#"3rd-party/catch.hpp"#<catch/catch.hpp>#' test/*.{cpp,h} || die
- rm 3rd-party/catch.hpp || die
-}
-
src_configure() {
./config.sh || die
}
src_compile() {
- # update object build deps to use system catch
- echo > mk/mk.deps || die
- emake depslist
-
emake prefix="/usr" CXX="$(tc-getCXX)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
}
src_test() {
# tests require UTF-8 locale
- emake test
+ emake CXX="$(tc-getCXX)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" test
# Tests fail if in ${S} rather than in ${S}/test
cd "${S}"/test || die
./test || die