summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-01-03 18:57:43 +0800
committerIan Delaney <idella4@gentoo.org>2016-01-03 19:00:02 +0800
commit15b619172a5718ddf3208e573a2f3654490adc10 (patch)
tree3fc52003b0c1cedd7a161e520677692cf4047c9c
parentnet-misc/vde: rm old vns. 2.3.1, 2.3.2, and 2.3.2-r1 (diff)
parentmedia-gfx/dispcalgui: Removed x-world/vrml media type from installed desktop ... (diff)
downloadgentoo-15b619172a5718ddf3208e573a2f3654490adc10.tar.gz
gentoo-15b619172a5718ddf3208e573a2f3654490adc10.tar.bz2
gentoo-15b619172a5718ddf3208e573a2f3654490adc10.zip
Merge remote-tracking branch 'remotes/CraigInches/dispcalGUI'
Pull request: https://github.com/gentoo/gentoo/pull/601
-rw-r--r--media-gfx/dispcalgui/Manifest1
-rw-r--r--media-gfx/dispcalgui/dispcalgui-3.0.6.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/media-gfx/dispcalgui/Manifest b/media-gfx/dispcalgui/Manifest
index 7edb7563f484..e38d41186b04 100644
--- a/media-gfx/dispcalgui/Manifest
+++ b/media-gfx/dispcalgui/Manifest
@@ -2,3 +2,4 @@ DIST dispcalGUI-1.2.7.0.tar.gz 3302318 SHA256 8032b71ced4d7f718f8aa50a5dfc925951
DIST dispcalGUI-2.0.0.0.tar.gz 5914050 SHA256 fad516999bd663cf870fad2869fc63a23f93820dffff9dbd1029369417a6b650 SHA512 14e1a5d921ed4aaa07bd96d2c4256ce080bc6201d7a5b2a6fa69ae9ac25b8d34c9b0f3b3dac3d2e9a7d4c5faa97682e10a4b15205098a454623ecdb4e09eb8a5 WHIRLPOOL 1c88bb5da2dcddc1848249ba76057e1e33480e8fc344af6c3348d933c9752cc09f91a03a61f18f71cae27473956ae0e518b85864b5a2eb6ce9caf074d59f167c
DIST dispcalGUI-2.5.0.0.tar.gz 6392054 SHA256 036a01a11551d990a6b84e241d131ca0b07d810d552b28332907aa6fb3cd4777 SHA512 d5cb2263739f9c46676222d20e570c161897af58bb359ed569a7690b6fc1ed83ce7e9862e7d69b1afb599b8035ca4f4abfccef83b877d98a34956535d2dd729b WHIRLPOOL 725de21d2d320ec74b6a7840cf5f251885b62946e20cfc7bed480f663c77116c9bac61b2df7e7ddfe7a0e7557269d864f0b88569e52463499eb310279fe66b7d
DIST dispcalGUI-2.6.0.0.tar.gz 6722168 SHA256 3087facf1fd7941b04df327903eb9a49511987a9b7afaada9ee8ca4600d0109f SHA512 0f7b1952588ee8e5c49f3ce3be41e53c0dd746b6fd660107e78ec16b392ebda9f8bc45550a119371b2197fd370f0e28e05aee47c71e26cfb8f648a6d66277454 WHIRLPOOL 84f050ed73200054b7dad53730a86490e44e751ab96ef4ef3faea279ac692ef76685c8992135085c43c3e258e2fc44c5a276217443adc67560eb23b376d535d7
+DIST dispcalGUI-3.0.6.0.tar.gz 9048298 SHA256 6432d47734ad18abccd4ef236eb7b721d7233529057da507fa36ccaf80de6d6a SHA512 cd91960b5ef00bb9f4e60000cc9117ffd6c8236e8b8dc65a76a4690da1c17eb5216385fbc1467ea842119fdbdc2d6937990b07ac999d193a0353249be8b8d795 WHIRLPOOL 629db4a3c293c93918b665b28246d047e1defcbafd82f96a8c662aabf4077b33a1492e37e9e1a5cbbe018b92048a98fcfa872057acad30df1d1a915222428a02
diff --git a/media-gfx/dispcalgui/dispcalgui-3.0.6.0.ebuild b/media-gfx/dispcalgui/dispcalgui-3.0.6.0.ebuild
new file mode 100644
index 000000000000..946362d18f0c
--- /dev/null
+++ b/media-gfx/dispcalgui/dispcalgui-3.0.6.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime eutils
+
+MY_PN="dispcalGUI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display Calibration and Characterization powered by Argyll CMS"
+HOMEPAGE="https://dispcalgui.hoech.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:2.8
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+# Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/dispcalGUI" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+# Remove deprecated Encoding key from .desktop file
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "Encoding=UTF-8" .); do
+ sed -e '/Encoding=UTF-8/d' -i "${offendingFile}" || \
+ die "removing deprecated Encoding key from .desktop files failed"
+ done
+
+# Remove x-world Media Type
+ cd "${S}/misc" || die "Cannot cd to misc directory."
+ sed -e 's/x\-world\/x\-vrml\;//g' -i "dispcalGUI-VRML-to-X3D-converter.desktop" || die "removing x-world media type failed"
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ #remove udev files
+ rm -rf "${D}"/etc/udev/rules.d
+}
+
+pkg_postinst() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}