summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMoritz Schlarb <moschlar@metalabs.de>2018-04-08 21:26:09 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-13 20:25:44 +0200
commit160214c6008e6fcc0a15c6a4688c5358b8a2e213 (patch)
tree3a613a89ef11aa34852e281ab0e2021f32538d0c
parentwww-apache/mod_ldap_userdir: use https in SRC_URI (diff)
downloadgentoo-160214c6008e6fcc0a15c6a4688c5358b8a2e213.tar.gz
gentoo-160214c6008e6fcc0a15c6a4688c5358b8a2e213.tar.bz2
gentoo-160214c6008e6fcc0a15c6a4688c5358b8a2e213.zip
net-libs/libsearpc: Fix SRC_URI
Upstream has an insane usage of git tags, so the tag is called v3.1-latest, but it is actually the library version 3.0.8. On the next version bump, we at least need to change the SRC_URI to use the snapshot tarball, but right now this would lead to mirrors serving the wrong tarball, which is probably not the best thing to do. Closes: https://bugs.gentoo.org/652760
-rw-r--r--net-libs/libsearpc/libsearpc-3.0.8-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/libsearpc/libsearpc-3.0.8-r3.ebuild b/net-libs/libsearpc/libsearpc-3.0.8-r3.ebuild
new file mode 100644
index 000000000000..23605ce88036
--- /dev/null
+++ b/net-libs/libsearpc/libsearpc-3.0.8-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-single-r1 vcs-snapshot
+
+DESCRIPTION="A simple C language RPC framework"
+HOMEPAGE="https://github.com/haiwen/libsearpc/ http://seafile.com/"
+#TODO: Use commit hash tarball on next version bump.
+SRC_URI="https://github.com/haiwen/${PN}/archive/v3.1-latest.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.0
+ >=dev-libs/jansson-2.2.1"
+RDEPEND="${DEPEND}
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+ sed -i -e "s/(DESTDIR)//" ${PN}.pc.in || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files, as recommended by ltprune.eclass
+ find "${ED}" -name '*.la' -delete || die
+ python_fix_shebang "${ED}"usr/bin
+}