summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-19 18:27:14 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-21 00:22:29 +0000
commit19975f88124c85d8a28e5b8a4f734edb93ea9f15 (patch)
tree139e97b66c8e9efef0a865f7dd145bddea54d8f3
parentdev-python/sphinx_rtd_theme: version bump (diff)
downloadgentoo-19975f88124c85d8a28e5b8a4f734edb93ea9f15.tar.gz
gentoo-19975f88124c85d8a28e5b8a4f734edb93ea9f15.tar.bz2
gentoo-19975f88124c85d8a28e5b8a4f734edb93ea9f15.zip
dev-python/numba: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-python/numba/numba-0.34.0.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/dev-python/numba/numba-0.34.0.ebuild b/dev-python/numba/numba-0.34.0.ebuild
index 7435caa43860..40122f0ca614 100644
--- a/dev-python/numba/numba-0.34.0.ebuild
+++ b/dev-python/numba/numba-0.34.0.ebuild
@@ -14,17 +14,19 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
+IUSE="examples test"
RDEPEND="
>=dev-python/llvmlite-0.19[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
virtual/python-enum34[${PYTHON_USEDEP}]
- virtual/python-funcsigs[${PYTHON_USEDEP}]"
+ virtual/python-funcsigs[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+"
DEPEND="${RDEPEND}
- test? ( virtual/python-singledispatch[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
-# doc building highly broken
python_test() {
cd "${BUILD_DIR}"/lib* || die
@@ -32,6 +34,10 @@ python_test() {
}
python_install_all() {
- use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
}