summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-23 10:36:03 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-23 10:37:21 +0100
commit19a15030e7a2eaf024c5b8c25c98e7269fc0a18d (patch)
tree0736341c3f7fbef31fcd6f687a87d09d175b8950
parentdev-python/tld: use pytest for tests (diff)
downloadgentoo-19a15030e7a2eaf024c5b8c25c98e7269fc0a18d.tar.gz
gentoo-19a15030e7a2eaf024c5b8c25c98e7269fc0a18d.tar.bz2
gentoo-19a15030e7a2eaf024c5b8c25c98e7269fc0a18d.zip
x11-wm/icewm: Bump to version 2.1.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--x11-wm/icewm/Manifest1
-rw-r--r--x11-wm/icewm/icewm-2.1.0.ebuild153
2 files changed, 154 insertions, 0 deletions
diff --git a/x11-wm/icewm/Manifest b/x11-wm/icewm/Manifest
index 7d96efce6032..cdcfc932326a 100644
--- a/x11-wm/icewm/Manifest
+++ b/x11-wm/icewm/Manifest
@@ -1,3 +1,4 @@
DIST icewm-1.9.2.tar.lz 1694602 BLAKE2B cf30a695ba48093b386aa2f3af5120e78a9fcc57da9038bcd546ade0986e1bc359a3da91d2eeeb8d3a105173f5d755223675a84b38cfc8c907269efd2561c706 SHA512 7b4f8c47c636a0113af576bc1bcd9fde111ae70eb0bcf21fb1d906ca43bea4d8b0337a728e5da35bcfeabd56c66fd0d14581d7377f063dd750fdf01362b24be2
DIST icewm-2.0.0.tar.lz 1694653 BLAKE2B 36feb02d653256b4d6755618da89400c3925279757da32695d6b8c2206d69228bcf392852eaba8b9096d06b60b5f021a0b6b474140a7754c4865d575d8a868dc SHA512 58b9a62d15add73c9c535e8602711636058b67b5e89b6189656a2d0668d2e647b9a59c45b5602f634ffd89abe7fb8a03be094524f3ff6d2b136bb8e21bc79fa3
DIST icewm-2.0.1.tar.lz 1694439 BLAKE2B 1476f33fa7350a98b7eca8c5c265455d0a78b28bcbd35ab78969b528ae02d3c960fb73cf2b24ea999ee5e08c9f0641d3502c7d5ed8b285777162c334d645b6db SHA512 ac4126b38d592aed60d2269f58c5a1612b61e871565e3c3e51bc2b430e4da6a4708f78e86c16091fa4dfb9eefd4109ae89102ab708e3bce9a44f1e5fe1970c59
+DIST icewm-2.1.0.tar.lz 1696214 BLAKE2B ba91eac4ea425fc9979d1c64fbc2a4c59f1d8004138f31b1e184484cfcaaca7c1a550cd160ff3683a4f663e54efdd5f8ded001317765485259a1f19b8de794a3 SHA512 a57ebbf76640b5296c90c105bdc9b9b2cc55546d324fa18b2e7bfc6bee4442b56176bda4a584d6a73b2297203e1966d7646354bb6e0baaf64fdf0acdb357ee58
diff --git a/x11-wm/icewm/icewm-2.1.0.ebuild b/x11-wm/icewm/icewm-2.1.0.ebuild
new file mode 100644
index 000000000000..ec1d0545c005
--- /dev/null
+++ b/x11-wm/icewm/icewm-2.1.0.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools unpacker
+
+DESCRIPTION="Ice Window Manager with Themes"
+HOMEPAGE="https://ice-wm.org/ https://github.com/ice-wm/icewm"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/ice-wm/icewm/releases/download/${PV}/${P}.tar.lz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="+alsa ao bidi debug +gdk-pixbuf imlib nls truetype uclibc xinerama"
+
+# Tests broken in all versions, patches welcome, bug #323907, #389533
+RESTRICT="test"
+
+REQUIRED_USE="|| ( alsa ao )"
+#?? ( gdk-pixbuf imlib )
+
+#fix for icewm preversion package names
+S="${WORKDIR}/${P/_}"
+
+# These are the core dependencies of icewm.
+# Look into configure.ac and search for PKG_CHECK_MODULES([CORE]
+CORE_DEPEND="
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrender
+"
+
+RDEPEND="
+ ${CORE_DEPEND}
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrandr
+ alsa? (
+ media-libs/alsa-lib
+ media-libs/libsndfile[alsa]
+ )
+ ao? (
+ media-libs/libao
+ media-libs/libsndfile
+ )
+ bidi? ( dev-libs/fribidi )
+ gdk-pixbuf? (
+ x11-libs/gdk-pixbuf-xlib
+ >=x11-libs/gdk-pixbuf-2.42.0:2
+ )
+ !gdk-pixbuf? (
+ imlib? (
+ gnome-base/librsvg:2
+ media-libs/imlib2
+ )
+ !imlib? (
+ media-libs/libpng:0=
+ virtual/jpeg
+ )
+ )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ $(unpacker_src_uri_depends)
+ x11-base/xorg-proto
+ gdk-pixbuf? ( gnome-base/librsvg:2 )
+"
+
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.19.8 )
+"
+
+pkg_pretend() {
+ if use gdk-pixbuf && use imlib ; then
+ einfo 'Confilcting USE flags have been enabled:'
+ einfo '"gdk-pixbuf" and "imlib" exclude each other!'
+ einfo 'Using "gdk-pixbuf".'
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local icesound
+ if use alsa && use ao ; then
+ icesound="alsa,ao"
+ elif use alsa ; then
+ icesound="alsa"
+ elif use ao ; then
+ icesound="ao"
+ fi
+
+ local myconf=(
+ --enable-logevents
+ --enable-xrandr
+ --with-cfgdir="${EPREFIX}"/etc/icewm
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ --with-icesound="${icesound}"
+ --with-libdir="${EPREFIX}"/usr/share/icewm
+ $(use_enable bidi fribidi)
+ $(use_enable debug)
+ $(use_enable debug logevents)
+ $(use_enable gdk-pixbuf)
+ $(use_enable imlib imlib2)
+ $(use_enable nls i18n)
+ $(use_enable nls)
+ $(use_enable xinerama)
+ )
+ if use truetype ; then
+ myconf+=(
+ --enable-shape
+ )
+ else
+ myconf+=(
+ --disable-xfreetype
+ --enable-corefonts
+ )
+ fi
+
+ econf "${myconf[@]}"
+
+ sed \
+ -e "s:/icewm-\$(VERSION)::" \
+ -e "s:ungif:gif:" \
+ -i src/Makefile || die
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog NEWS README.md TODO VERSION )
+
+ default
+
+ docinto html
+ dodoc doc/icewm.html
+ dodoc man/*.html
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/icewm"
+}