summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorband-a-prend <torokhov-s-a@yandex.ru>2019-12-26 18:01:30 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-01-06 17:40:08 +0200
commit1b62211cc285ae25d4ed511b8cef5901c7f07941 (patch)
tree3c110db64fd42e223cb56c8e6b98b74b489c0c5d
parentdev-python/python-mpd: Drop 0.5.5 (diff)
downloadgentoo-1b62211cc285ae25d4ed511b8cef5901c7f07941.tar.gz
gentoo-1b62211cc285ae25d4ed511b8cef5901c7f07941.tar.bz2
gentoo-1b62211cc285ae25d4ed511b8cef5901c7f07941.zip
sci-libs/cantera: add support sci-libs/sundials-5.0, dev-lang/python-3.8
Simple fix for Sundials-5.0 and Python-3.8 compatibility. The Sundials-5.0 has the same API as Sundials-4.x for CVODES function. Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/14126 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sci-libs/cantera/cantera-2.4.0-r2.ebuild4
-rw-r--r--sci-libs/cantera/files/cantera_2.4.0_sundials4.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/sci-libs/cantera/cantera-2.4.0-r2.ebuild b/sci-libs/cantera/cantera-2.4.0-r2.ebuild
index 57b64872624..79b1572e51c 100644
--- a/sci-libs/cantera/cantera-2.4.0-r2.ebuild
+++ b/sci-libs/cantera/cantera-2.4.0-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
FORTRAN_NEEDED=fortran
FORTRAN_STANDARD=90
@@ -30,7 +30,7 @@ RDEPEND="
python? (
dev-python/numpy[${PYTHON_USEDEP}]
)
- <sci-libs/sundials-5.0.0:0=
+ <sci-libs/sundials-5.1.0:0=
"
DEPEND="
diff --git a/sci-libs/cantera/files/cantera_2.4.0_sundials4.patch b/sci-libs/cantera/files/cantera_2.4.0_sundials4.patch
index c745f6b6f7f..0345a98e252 100644
--- a/sci-libs/cantera/files/cantera_2.4.0_sundials4.patch
+++ b/sci-libs/cantera/files/cantera_2.4.0_sundials4.patch
@@ -47,7 +47,7 @@ diff -Nur old/SConstruct new/SConstruct
# Ignore the minor version, e.g. 2.4.x -> 2.4
env['sundials_version'] = '.'.join(sundials_version.split('.')[:2])
- if env['sundials_version'] not in ('2.4','2.5','2.6','2.7','3.0','3.1','3.2'):
-+ if env['sundials_version'] not in ('2.4','2.5','2.6','2.7','3.0','3.1','3.2','4.0','4.1'):
++ if env['sundials_version'] not in ('2.4','2.5','2.6','2.7','3.0','3.1','3.2','4.0','4.1','5.0'):
print("""ERROR: Sundials version %r is not supported.""" % env['sundials_version'])
sys.exit(1)
print("""INFO: Using system installation of Sundials version %s.""" % sundials_version)