summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-05-27 17:05:20 -0400
committerDavid Seifert <soap@gentoo.org>2017-06-02 08:56:49 +0200
commit1b99de510adbadfd03778f8cdf753ffd1b1e24db (patch)
treea8eb32ced5fb2139e87e05833288c4eef5ed8086
parentwww-misc/htdig: Fix building with GCC-6 (diff)
downloadgentoo-1b99de510adbadfd03778f8cdf753ffd1b1e24db.tar.gz
gentoo-1b99de510adbadfd03778f8cdf753ffd1b1e24db.tar.bz2
gentoo-1b99de510adbadfd03778f8cdf753ffd1b1e24db.zip
games-sports/torcs: Fix building with GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=594670 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4780
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-gcc6.patch11
-rw-r--r--games-sports/torcs/torcs-1.3.6-r1.ebuild3
-rw-r--r--games-sports/torcs/torcs-1.3.6.ebuild5
3 files changed, 16 insertions, 3 deletions
diff --git a/games-sports/torcs/files/torcs-1.3.6-gcc6.patch b/games-sports/torcs/files/torcs-1.3.6-gcc6.patch
new file mode 100644
index 000000000000..6daf22a81b11
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-gcc6.patch
@@ -0,0 +1,11 @@
+--- a/src/drivers/olethros/geometry.cpp
++++ b/src/drivers/olethros/geometry.cpp
+@@ -27,6 +27,8 @@
+ #ifdef WIN32
+ #include <float.h>
+ #define isnan _isnan
++#elif __cplusplus >= 201103L
++using std::isnan;
+ #endif
+
+
diff --git a/games-sports/torcs/torcs-1.3.6-r1.ebuild b/games-sports/torcs/torcs-1.3.6-r1.ebuild
index da2ecb7763bc..c92083f6cbc0 100644
--- a/games-sports/torcs/torcs-1.3.6-r1.ebuild
+++ b/games-sports/torcs/torcs-1.3.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -33,6 +33,7 @@ PATCHES=(
"${FILESDIR}"/${P}-flags.patch
"${FILESDIR}"/${P}-format.patch
"${FILESDIR}"/${P}-noXmuXt.patch
+ "${FILESDIR}"/${P}-gcc6.patch
)
src_prepare() {
diff --git a/games-sports/torcs/torcs-1.3.6.ebuild b/games-sports/torcs/torcs-1.3.6.ebuild
index e447c13937af..c37169833555 100644
--- a/games-sports/torcs/torcs-1.3.6.ebuild
+++ b/games-sports/torcs/torcs-1.3.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -33,7 +33,8 @@ src_prepare() {
"${FILESDIR}"/${P}-as-needed.patch \
"${FILESDIR}"/${P}-flags.patch \
"${FILESDIR}"/${P}-format.patch \
- "${FILESDIR}"/${P}-noXmuXt.patch
+ "${FILESDIR}"/${P}-noXmuXt.patch \
+ "${FILESDIR}"/${P}-gcc6.patch
eautoreconf
ecvs_clean
}