summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-10-13 15:50:30 +0200
committerJeroen Roovers <jer@gentoo.org>2017-10-13 15:50:41 +0200
commit1d1d6e3080bcdb6a5a38ae01ffa074e73eb05726 (patch)
tree84803ccdc1e94bff101aaac19b5b6b2ca18fea59
parentnet-misc/pps-tools: Bump to v1.0.1 (diff)
downloadgentoo-1d1d6e3080bcdb6a5a38ae01ffa074e73eb05726.tar.gz
gentoo-1d1d6e3080bcdb6a5a38ae01ffa074e73eb05726.tar.bz2
gentoo-1d1d6e3080bcdb6a5a38ae01ffa074e73eb05726.zip
x11-misc/xsetleds: Fix HOMEPAGE, add alternative SRC_URI.
Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild b/x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild
new file mode 100644
index 000000000000..a7fea73b665d
--- /dev/null
+++ b/x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="small tool to report and change the keyboard LED states of an X display"
+HOMEPAGE="https://github.com/bmeurer/xsetleds"
+SRC_URI="
+ ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/src/${P}.tar.gz
+ https://dev.gentoo.org/~jer/${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-assignment.patch
+ "${FILESDIR}"/${P}-isalpha.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+DOCS=( AUTHORS ChangeLog README TODO )