summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-03-16 16:00:11 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-03-16 16:00:51 +0100
commit1f07e619398916a141c1f0ba46d703807060d878 (patch)
tree570bf91a5231d9ec38ef9cecee9c7e7d1dc5a8ff
parentgames-util/xpadneo: new package 0.9 (diff)
downloadgentoo-1f07e619398916a141c1f0ba46d703807060d878.tar.gz
gentoo-1f07e619398916a141c1f0ba46d703807060d878.tar.bz2
gentoo-1f07e619398916a141c1f0ba46d703807060d878.zip
sys-apps/attr: Bump to version 2.5.1
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-apps/attr/Manifest1
-rw-r--r--sys-apps/attr/attr-2.5.1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/sys-apps/attr/Manifest b/sys-apps/attr/Manifest
index 19ee562e8526..c3a9128a6da9 100644
--- a/sys-apps/attr/Manifest
+++ b/sys-apps/attr/Manifest
@@ -1,2 +1,3 @@
DIST attr-2.4.48.tar.gz 467840 BLAKE2B 8fa6a5013b927850868b6913d026f23f116b75da3925d5da5eea007e14f5d9e309f98290b7ffaa6c62f620ff8f3ec7bfb3a1fcb04f3c0c072fca5feacaf804c0 SHA512 75f870a0e6e19b8975f3fdceee786fbaff3eadaa9ab9af01996ffa8e50fe5b2bba6e4c22c44a6722d11b55feb9e89895d0151d6811c1d2b475ef4ed145f0c923
DIST attr-2.5.0.tar.gz 465575 BLAKE2B b50c6b741543140099e7f31fcc327d4547cda41f1b14159664096b571c5c14ed7279992e94fdd9bc23d5618715a7d4fe8d45ba8d5cc2941ac6a4d242bc80ee09 SHA512 900e66d13acd022f52986d4159925b23e60f9ef5d11983b16d9dfe4a98fd70eea5f78e18f3694d8adea1c422324772af4da6b5659d755ed37484b428e28bb5fc
+DIST attr-2.5.1.tar.gz 465714 BLAKE2B 05928f8274b0b4beee31b329c8459436c5b9019ebd2f937667b7beb8df7a455c48742a90d9c4faca5c0b38c9c3812043d3d66f9587108d3424c6184fef494b56 SHA512 8b4c043d61f8f3e0cd098e701181069f51117b85fd6ba18bfe9af77d894ea671232377d4793ffc822e9259ceee6ac71d75732eb93b2830c6cb5d0d918ba2d21b
diff --git a/sys-apps/attr/attr-2.5.1.ebuild b/sys-apps/attr/attr-2.5.1.ebuild
new file mode 100644
index 000000000000..7465baca96b8
--- /dev/null
+++ b/sys-apps/attr/attr-2.5.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic libtool toolchain-funcs multilib-minimal usr-ldscript
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/${PN}.git"
+
+ inherit autotools git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="https://savannah.nongnu.org/projects/attr"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+IUSE="debug nls static-libs"
+
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ po/update-potfiles || die
+ eautopoint
+ eautoreconf
+ else
+ elibtoolize #580792
+ fi
+}
+
+src_configure() {
+ # Remove -flto* from flags as this breaks binaries (bug #644048)
+ filter-flags -flto*
+ append-ldflags "-Wl,--no-gc-sections" #700116
+ tc-ld-disable-gold #644048
+ append-lfs-flags #760857
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/bin
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_enable nls)
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable debug)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ # Sanity check until we track down why this is happening. #644048
+ local lib="${ED}/usr/$(get_libdir)/libattr.so.1"
+ if [[ -e ${lib} ]] ; then
+ local versions=$($(tc-getREADELF) -V "${lib}")
+ local symbols=$($(tc-getREADELF) -sW "${lib}")
+ if [[ "${versions}" != *"ATTR_1.0"* || \
+ "${versions}" != *"ATTR_1.1"* || \
+ "${versions}" != *"ATTR_1.2"* || \
+ "${versions}" != *"ATTR_1.3"* || \
+ "${symbols}" != *"getxattr@ATTR_1.0"* ]] ; then
+ echo "# readelf -V ${lib}"
+ echo "${versions}"
+ echo "# readelf -sW ${lib}"
+ echo "${symbols}"
+ die "symbol version sanity check failed; please comment on https://bugs.gentoo.org/644048"
+ else
+ einfo "${lib} passed symbol checks"
+ fi
+ fi
+
+ if multilib_is_native_abi; then
+ # we install attr into /bin, so we need the shared lib with it
+ gen_usr_ldscript -a attr
+ fi
+
+ # Add a wrapper until people upgrade.
+ insinto /usr/include/attr
+ newins "${FILESDIR}"/xattr-shim.h xattr.h
+}
+
+multilib_src_install_all() {
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+
+ einstalldocs
+}