summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-04-02 14:33:23 +0300
committerMart Raudsepp <leio@gentoo.org>2017-04-02 15:58:49 +0300
commit1f1cbc2c872bef6db39e77916d63ff9415ee9656 (patch)
tree2e9f5e385a68978d652731044477219b799ac826
parentx11-wm/mutter: remove old (diff)
downloadgentoo-1f1cbc2c872bef6db39e77916d63ff9415ee9656.tar.gz
gentoo-1f1cbc2c872bef6db39e77916d63ff9415ee9656.tar.bz2
gentoo-1f1cbc2c872bef6db39e77916d63ff9415ee9656.zip
gnome-base/gnome-shell: remove old
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--gnome-base/gnome-shell/Manifest2
-rw-r--r--gnome-base/gnome-shell/files/gnome-shell-3.14.0-defaults.patch25
-rw-r--r--gnome-base/gnome-shell/gnome-shell-3.20.4.ebuild217
-rw-r--r--gnome-base/gnome-shell/gnome-shell-3.22.2.ebuild206
4 files changed, 0 insertions, 450 deletions
diff --git a/gnome-base/gnome-shell/Manifest b/gnome-base/gnome-shell/Manifest
index 2a09d6cd0fb..46b16e52128 100644
--- a/gnome-base/gnome-shell/Manifest
+++ b/gnome-base/gnome-shell/Manifest
@@ -1,3 +1 @@
-DIST gnome-shell-3.20.4.tar.xz 1662400 SHA256 0c13eba5ecd3b516538815ab33765ae04bd6faf1549407e81f3bf17b08f2a94d SHA512 40622be949b7d331073982f70ff8ae9b80005e1bf9f5251f0afcd10e564dd48c1d79ae2d874015794c7f99411befd4fc4f586d87a752148aa6097825b1bf931f WHIRLPOOL 226fb3adca9d4aef97bee50d6678c360cf74727a47c9018a16cfbe0f5d6ec32d2282a7965332021643392c1fbcb415a715a41a761d5998f82268d318c40b1942
-DIST gnome-shell-3.22.2.tar.xz 1949420 SHA256 d80f4eb662ada325165b066112e924f4c16044f153c274c886d7f99b9ddc559b SHA512 4f379e15324215e65d8fb29d2112dedcc47ede8087e3beff2edf205a901453f4682ba6ed8e841e157bab5490ed9598f4f5e799c56694442d23f5e0515483a4ff WHIRLPOOL 480402cb2cf75228800d21117b6c6235c7f6c881ced07a314d462971ca6b5740966452339b15ce706c333cb8c47a41c70cafc185364ec2d8010b71878eb35b1c
DIST gnome-shell-3.22.3.tar.xz 1952576 SHA256 d1e6bd80ddd1fef92d80b518d4dbeffa296e8f003402551b8c37c42744b7d42f SHA512 47d67910b321a182d3ecd41f20cd923ec433cc93ab04b0b31351ca0229505ecbf343b1307585e557ee757845dc09b2371b0c2197717ed532b71878c186337ee9 WHIRLPOOL 9487f2626cc3ec0b3410c5ec65ceabb114e82d256ab1190464c6c787ca7cfd9e617358c19f84d64955943434b96c0521b5e57ea868da1c291a4874f1f3181613
diff --git a/gnome-base/gnome-shell/files/gnome-shell-3.14.0-defaults.patch b/gnome-base/gnome-shell/files/gnome-shell-3.14.0-defaults.patch
deleted file mode 100644
index b60642253dd..00000000000
--- a/gnome-base/gnome-shell/files/gnome-shell-3.14.0-defaults.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 6b658660e822a550da55c735c826ec75b6c0efee Mon Sep 17 00:00:00 2001
-From: Gilles Dartiguelongue <eva@gentoo.org>
-Date: Tue, 10 Dec 2013 23:33:51 +0100
-Subject: [PATCH 1/3] Alter list of default applications
-
----
- data/org.gnome.shell.gschema.xml.in.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/data/org.gnome.shell.gschema.xml.in.in b/data/org.gnome.shell.gschema.xml.in.in
-index 92cef3f..9e783bb 100644
---- a/data/org.gnome.shell.gschema.xml.in.in
-+++ b/data/org.gnome.shell.gschema.xml.in.in
-@@ -31,7 +31,7 @@
- </_description>
- </key>
- <key name="favorite-apps" type="as">
-- <default>[ 'epiphany.desktop', 'evolution.desktop', 'rhythmbox.desktop', 'shotwell.desktop', 'org.gnome.Nautilus.desktop', 'org.gnome.Software.desktop' ]</default>
-+ <default>[ 'chromium-browser-chromium.desktop', 'firefox.desktop', 'firefox-bin.desktop', 'evolution.desktop', 'rhythmbox.desktop', 'shotwell.desktop', 'org.gnome.Nautilus.desktop', 'org.gnome.Software.desktop' ]</default>
- <_summary>List of desktop file IDs for favorite applications</_summary>
- <_description>
- The applications corresponding to these identifiers
---
-2.1.2
-
diff --git a/gnome-base/gnome-shell/gnome-shell-3.20.4.ebuild b/gnome-base/gnome-shell/gnome-shell-3.20.4.ebuild
deleted file mode 100644
index 9b5ee8e972c..00000000000
--- a/gnome-base/gnome-shell/gnome-shell-3.20.4.ebuild
+++ /dev/null
@@ -1,217 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python{3_4,3_5} )
-
-inherit autotools eutils gnome2 multilib pax-utils python-r1 systemd
-
-DESCRIPTION="Provides core UI functions for the GNOME 3 desktop"
-HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="0"
-IUSE="+bluetooth +networkmanager +nls -openrc-force"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 x86"
-
-# libXfixes-5.0 needed for pointer barriers
-# FIXME:
-# * gstreamer support is currently automagic
-COMMON_DEPEND="
- >=app-accessibility/at-spi2-atk-2.5.3
- >=dev-libs/atk-2[introspection]
- >=app-crypt/gcr-3.7.5[introspection]
- >=dev-libs/glib-2.45.3:2[dbus]
- >=dev-libs/gjs-1.39
- >=dev-libs/gobject-introspection-1.45.4:=
- dev-libs/libical:=
- >=x11-libs/gtk+-3.15.0:3[introspection]
- >=media-libs/clutter-1.21.5:1.0[introspection]
- >=dev-libs/json-glib-0.13.2
- >=dev-libs/libcroco-0.6.8:0.6
- >=gnome-base/gnome-desktop-3.7.90:3=[introspection]
- >=gnome-base/gsettings-desktop-schemas-3.19.2
- >=gnome-base/gnome-keyring-3.3.90
- gnome-base/libgnome-keyring
- >=gnome-extra/evolution-data-server-3.17.2:=
- >=media-libs/gstreamer-0.11.92:1.0
- >=net-im/telepathy-logger-0.2.4[introspection]
- >=net-libs/telepathy-glib-0.19[introspection]
- >=sys-auth/polkit-0.100[introspection]
- >=x11-libs/libXfixes-5.0
- x11-libs/libXtst
- >=x11-wm/mutter-3.20.2[introspection]
- >=x11-libs/startup-notification-0.11
-
- ${PYTHON_DEPS}
- dev-python/pygobject:3[${PYTHON_USEDEP}]
-
- dev-libs/dbus-glib
- dev-libs/libxml2:2
- gnome-base/librsvg
- media-libs/libcanberra[gtk3]
- media-libs/mesa
- >=media-sound/pulseaudio-2
- >=net-libs/libsoup-2.40:2.4[introspection]
- x11-libs/libX11
- x11-libs/gdk-pixbuf:2[introspection]
- x11-libs/pango[introspection]
- x11-apps/mesa-progs
-
- bluetooth? ( >=net-wireless/gnome-bluetooth-3.9[introspection] )
- networkmanager? (
- app-crypt/libsecret
- >=gnome-extra/nm-applet-0.9.8
- >=net-misc/networkmanager-0.9.8:=[introspection] )
-"
-# Runtime-only deps are probably incomplete and approximate.
-# Introspection deps generated using:
-# grep -roe "imports.gi.*" gnome-shell-* | cut -f2 -d: | sort | uniq
-# Each block:
-# 1. Pull in polkit-0.101 for pretty authorization dialogs
-# 2. Introspection stuff needed via imports.gi.*
-# 3. gnome-session is needed for gnome-session-quit
-# 4. Control shell settings
-# 5. Systemd needed for suspending support
-# 6. xdg-utils needed for xdg-open, used by extension tool
-# 7. gnome-icon-theme-symbolic and dejavu font neeed for various icons & arrows
-# 8. IBus is needed for nls integration
-# 9. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c
-RDEPEND="${COMMON_DEPEND}
- >=sys-auth/polkit-0.101[introspection]
-
- >=app-accessibility/caribou-0.4.8
- media-libs/cogl[introspection]
- >=sys-apps/accountsservice-0.6.14[introspection]
- >=sys-power/upower-0.99:=[introspection]
-
- >=gnome-base/gnome-session-2.91.91
- >=gnome-base/gnome-settings-daemon-3.8.3
-
- !openrc-force? ( >=sys-apps/systemd-31 )
-
- x11-misc/xdg-utils
-
- media-fonts/dejavu
- >=x11-themes/adwaita-icon-theme-3.19.90
-
- networkmanager? (
- net-misc/mobile-broadband-provider-info
- sys-libs/timezone-data )
- nls? ( >=app-i18n/ibus-1.4.99[dconf(+),gtk3,introspection] )
-"
-# avoid circular dependency, see bug #546134
-PDEPEND="
- >=gnome-base/gdm-3.5[introspection]
- >=gnome-base/gnome-control-center-3.8.3[bluetooth(+)?,networkmanager(+)?]
-"
-DEPEND="${COMMON_DEPEND}
- dev-libs/libxslt
- >=dev-util/gtk-doc-am-1.17
- >=dev-util/intltool-0.40
- gnome-base/gnome-common
- virtual/pkgconfig
- !!=dev-lang/spidermonkey-1.8.2*
-"
-# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
-# https://bugs.gentoo.org/show_bug.cgi?id=360413
-
-src_prepare() {
- # Change favorites defaults, bug #479918
- eapply "${FILESDIR}"/${PN}-3.14.0-defaults.patch
-
- # Fix automagic gnome-bluetooth dep, bug #398145
- eapply "${FILESDIR}"/${PN}-3.12-bluetooth-flag.patch
-
- # Fix silent bluetooth linking failure with ld.gold, bug #503952
- # https://bugzilla.gnome.org/show_bug.cgi?id=726435
- # This shouldn't be needed per upstream
-# epatch "${FILESDIR}"/${PN}-3.14.0-bluetooth-gold.patch
-
- eautoreconf
- gnome2_src_prepare
-}
-
-src_configure() {
- # Do not error out on warnings
- gnome2_src_configure \
- --enable-browser-plugin \
- --enable-man \
- $(use_enable !openrc-force systemd) \
- $(use_with bluetooth) \
- $(use_enable networkmanager) \
- BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins
-}
-
-src_install() {
- gnome2_src_install
- python_replicate_script "${ED}/usr/bin/gnome-shell-extension-tool"
- python_replicate_script "${ED}/usr/bin/gnome-shell-perf-tool"
-
- # Required for gnome-shell on hardened/PaX, bug #398941
- # Future-proof for >=spidermonkey-1.8.7 following polkit's example
- if has_version '<dev-lang/spidermonkey-1.8.7'; then
- pax-mark mr "${ED}usr/bin/gnome-shell"{,-extension-prefs}
- elif has_version '>=dev-lang/spidermonkey-1.8.7[jit]'; then
- pax-mark m "${ED}usr/bin/gnome-shell"{,-extension-prefs}
- # Required for gnome-shell on hardened/PaX #457146 and #457194
- # PaX EMUTRAMP need to be on
- elif has_version '>=dev-libs/libffi-3.0.13[pax_kernel]'; then
- pax-mark E "${ED}usr/bin/gnome-shell"{,-extension-prefs}
- else
- pax-mark m "${ED}usr/bin/gnome-shell"{,-extension-prefs}
- fi
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- if ! has_version 'media-libs/gst-plugins-good:1.0' || \
- ! has_version 'media-plugins/gst-plugins-vpx:1.0'; then
- ewarn "To make use of GNOME Shell's built-in screen recording utility,"
- ewarn "you need to either install media-libs/gst-plugins-good:1.0"
- ewarn "and media-plugins/gst-plugins-vpx:1.0, or use dconf-editor to change"
- ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
- fi
-
- if ! has_version ">=x11-base/xorg-server-1.11"; then
- ewarn "If you use multiple screens, it is highly recommended that you"
- ewarn "upgrade to >=x11-base/xorg-server-1.11 to be able to make use of"
- ewarn "pointer barriers which will make it easier to use hot corners."
- fi
-
- if has_version "<x11-drivers/ati-drivers-12"; then
- ewarn "GNOME Shell has been reported to show graphical corruption under"
- ewarn "x11-drivers/ati-drivers-11.*; you may want to switch to open-source"
- ewarn "drivers."
- fi
-
- if ! has_version "media-libs/mesa[llvm]"; then
- elog "llvmpipe is used as fallback when no 3D acceleration"
- elog "is available. You will need to enable llvm USE for"
- elog "media-libs/mesa."
- fi
-
- # https://bugs.gentoo.org/show_bug.cgi?id=563084
- if has_version "x11-drivers/nvidia-drivers[-kms]"; then
- ewarn "You will need to enable kms support in x11-drivers/nvidia-drivers,"
- ewarn "otherwise Gnome will fail to start"
- fi
-
- if ! systemd_is_booted; then
- ewarn "${PN} needs Systemd to be *running* for working"
- ewarn "properly. Please follow this guide to migrate:"
- ewarn "https://wiki.gentoo.org/wiki/Systemd"
- fi
-
- if use openrc-force; then
- ewarn "You are enabling 'openrc-force' USE flag to skip systemd requirement,"
- ewarn "this can lead to unexpected problems and is not supported neither by"
- ewarn "upstream neither by Gnome Gentoo maintainers. If you suffer any problem,"
- ewarn "you will need to disable this USE flag system wide and retest before"
- ewarn "opening any bug report."
- fi
-}
diff --git a/gnome-base/gnome-shell/gnome-shell-3.22.2.ebuild b/gnome-base/gnome-shell/gnome-shell-3.22.2.ebuild
deleted file mode 100644
index ca7a754d5ec..00000000000
--- a/gnome-base/gnome-shell/gnome-shell-3.22.2.ebuild
+++ /dev/null
@@ -1,206 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python{3_4,3_5} )
-
-inherit autotools gnome2 multilib pax-utils python-r1 systemd
-
-DESCRIPTION="Provides core UI functions for the GNOME 3 desktop"
-HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="0"
-IUSE="+bluetooth +networkmanager nsplugin +nls -openrc-force"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
-
-# libXfixes-5.0 needed for pointer barriers
-# FIXME:
-# * gstreamer support is currently automagic
-COMMON_DEPEND="
- >=app-accessibility/at-spi2-atk-2.5.3
- >=dev-libs/atk-2[introspection]
- >=app-crypt/gcr-3.7.5[introspection]
- >=dev-libs/glib-2.45.3:2[dbus]
- >=dev-libs/gjs-1.39
- >=dev-libs/gobject-introspection-1.49.1:=
- dev-libs/libical:=
- >=x11-libs/gtk+-3.15.0:3[introspection]
- >=dev-libs/libcroco-0.6.8:0.6
- >=gnome-base/gnome-desktop-3.7.90:3=[introspection]
- >=gnome-base/gsettings-desktop-schemas-3.21.3
- >=gnome-extra/evolution-data-server-3.17.2:=
- >=media-libs/gstreamer-0.11.92:1.0
- >=net-im/telepathy-logger-0.2.4[introspection]
- >=net-libs/telepathy-glib-0.19[introspection]
- >=sys-auth/polkit-0.100[introspection]
- >=x11-libs/libXfixes-5.0
- x11-libs/libXtst
- >=x11-wm/mutter-3.22.1[introspection]
- >=x11-libs/startup-notification-0.11
-
- ${PYTHON_DEPS}
- dev-python/pygobject:3[${PYTHON_USEDEP}]
-
- dev-libs/dbus-glib
- dev-libs/libxml2:2
- media-libs/libcanberra[gtk3]
- media-libs/mesa
- >=media-sound/pulseaudio-2
- >=net-libs/libsoup-2.40:2.4[introspection]
- x11-libs/libX11
- x11-libs/gdk-pixbuf:2[introspection]
-
- x11-apps/mesa-progs
-
- bluetooth? ( >=net-wireless/gnome-bluetooth-3.9[introspection] )
- networkmanager? (
- app-crypt/libsecret
- >=gnome-extra/nm-applet-0.9.8
- >=net-misc/networkmanager-0.9.8:=[introspection] )
- nsplugin? ( >=dev-libs/json-glib-0.13.2 )
-"
-# Runtime-only deps are probably incomplete and approximate.
-# Introspection deps generated using:
-# grep -roe "imports.gi.*" gnome-shell-* | cut -f2 -d: | sort | uniq
-# Each block:
-# 1. Introspection stuff needed via imports.gi.*
-# 2. gnome-session is needed for gnome-session-quit
-# 3. Control shell settings
-# 4. Systemd needed for suspending support
-# 5. xdg-utils needed for xdg-open, used by extension tool
-# 6. adwaita-icon-theme and dejavu font neeed for various icons & arrows
-# 7. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c
-# 8. IBus is needed for nls integration
-RDEPEND="${COMMON_DEPEND}
- app-accessibility/at-spi2-core:2[introspection]
- >=app-accessibility/caribou-0.4.8
- dev-libs/libgweather:2[introspection]
- >=sys-apps/accountsservice-0.6.14[introspection]
- >=sys-power/upower-0.99:=[introspection]
- x11-libs/pango[introspection]
-
- >=gnome-base/gnome-session-2.91.91
- >=gnome-base/gnome-settings-daemon-3.8.3
-
- !openrc-force? ( >=sys-apps/systemd-31 )
-
- x11-misc/xdg-utils
-
- media-fonts/dejavu
- >=x11-themes/adwaita-icon-theme-3.19.90
-
- networkmanager? (
- net-misc/mobile-broadband-provider-info
- sys-libs/timezone-data )
- nls? ( >=app-i18n/ibus-1.4.99[dconf(+),gtk3,introspection] )
-"
-# avoid circular dependency, see bug #546134
-PDEPEND="
- >=gnome-base/gdm-3.5[introspection]
- >=gnome-base/gnome-control-center-3.8.3[bluetooth(+)?,networkmanager(+)?]
-"
-DEPEND="${COMMON_DEPEND}
- dev-libs/libxslt
- >=dev-util/gdbus-codegen-2.45.3
- >=dev-util/gtk-doc-am-1.17
- gnome-base/gnome-common
- >=sys-devel/gettext-0.19.6
- virtual/pkgconfig
- !!=dev-lang/spidermonkey-1.8.2*
-"
-# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
-# https://bugs.gentoo.org/show_bug.cgi?id=360413
-
-src_prepare() {
- # Change favorites defaults, bug #479918
- eapply "${FILESDIR}"/${PN}-3.22.0-defaults.patch
-
- # Fix automagic gnome-bluetooth dep, bug #398145
- eapply "${FILESDIR}"/${PN}-3.12-bluetooth-flag.patch
-
- # Add missing path to libmutter-clutter when building .gir, bug #597842
- eapply "${FILESDIR}"/${PN}-3.22.0-gir-build-fix.patch
-
- eautoreconf
- gnome2_src_prepare
-}
-
-src_configure() {
- # Do not error out on warnings
- gnome2_src_configure \
- --enable-browser-plugin \
- --enable-man \
- $(use_enable !openrc-force systemd) \
- $(use_with bluetooth) \
- $(use_enable networkmanager) \
- $(use_enable nsplugin browser-plugin) \
- BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins
-}
-
-src_install() {
- gnome2_src_install
- python_replicate_script "${ED}/usr/bin/gnome-shell-extension-tool"
- python_replicate_script "${ED}/usr/bin/gnome-shell-perf-tool"
-
- # Required for gnome-shell on hardened/PaX, bug #398941
- # Future-proof for >=spidermonkey-1.8.7 following polkit's example
- if has_version '<dev-lang/spidermonkey-1.8.7'; then
- pax-mark mr "${ED}usr/bin/gnome-shell"{,-extension-prefs}
- elif has_version '>=dev-lang/spidermonkey-1.8.7[jit]'; then
- pax-mark m "${ED}usr/bin/gnome-shell"{,-extension-prefs}
- # Required for gnome-shell on hardened/PaX #457146 and #457194
- # PaX EMUTRAMP need to be on
- elif has_version '>=dev-libs/libffi-3.0.13[pax_kernel]'; then
- pax-mark E "${ED}usr/bin/gnome-shell"{,-extension-prefs}
- else
- pax-mark m "${ED}usr/bin/gnome-shell"{,-extension-prefs}
- fi
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- if ! has_version 'media-libs/gst-plugins-good:1.0' || \
- ! has_version 'media-plugins/gst-plugins-vpx:1.0'; then
- ewarn "To make use of GNOME Shell's built-in screen recording utility,"
- ewarn "you need to either install media-libs/gst-plugins-good:1.0"
- ewarn "and media-plugins/gst-plugins-vpx:1.0, or use dconf-editor to change"
- ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
- fi
-
- if has_version "<x11-drivers/ati-drivers-12"; then
- ewarn "GNOME Shell has been reported to show graphical corruption under"
- ewarn "x11-drivers/ati-drivers-11.*; you may want to switch to open-source"
- ewarn "drivers."
- fi
-
- if ! has_version "media-libs/mesa[llvm]"; then
- elog "llvmpipe is used as fallback when no 3D acceleration"
- elog "is available. You will need to enable llvm USE for"
- elog "media-libs/mesa."
- fi
-
- # https://bugs.gentoo.org/show_bug.cgi?id=563084
- if has_version "x11-drivers/nvidia-drivers[-kms]"; then
- ewarn "You will need to enable kms support in x11-drivers/nvidia-drivers,"
- ewarn "otherwise Gnome will fail to start"
- fi
-
- if ! systemd_is_booted; then
- ewarn "${PN} needs Systemd to be *running* for working"
- ewarn "properly. Please follow this guide to migrate:"
- ewarn "https://wiki.gentoo.org/wiki/Systemd"
- fi
-
- if use openrc-force; then
- ewarn "You are enabling 'openrc-force' USE flag to skip systemd requirement,"
- ewarn "this can lead to unexpected problems and is not supported neither by"
- ewarn "upstream neither by Gnome Gentoo maintainers. If you suffer any problem,"
- ewarn "you will need to disable this USE flag system wide and retest before"
- ewarn "opening any bug report."
- fi
-}