summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-07-27 18:45:19 -0500
committerMatt Turner <mattst88@gentoo.org>2018-07-27 17:38:28 -0700
commit1f298106851405e8b92197e703a360f01cbff918 (patch)
treeb1642fd1090e102190af4c92227594286bcc0510
parentx11-misc/xbitmaps: port to EAPI 7 (diff)
downloadgentoo-1f298106851405e8b92197e703a360f01cbff918.tar.gz
gentoo-1f298106851405e8b92197e703a360f01cbff918.tar.bz2
gentoo-1f298106851405e8b92197e703a360f01cbff918.zip
x11-misc/xcompmgr: port to EAPI 7
Package-Manager: Portage-2.3.41, Repoman-2.3.9
-rw-r--r--x11-misc/xcompmgr/xcompmgr-1.1.7-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/xcompmgr/xcompmgr-1.1.7-r1.ebuild b/x11-misc/xcompmgr/xcompmgr-1.1.7-r1.ebuild
new file mode 100644
index 000000000000..c271eab9415b
--- /dev/null
+++ b/x11-misc/xcompmgr/xcompmgr-1.1.7-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="X Compositing manager"
+HOMEPAGE="https://freedesktop.org/wiki/Software/xapps"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/app/glxcompmgr.git"
+ inherit autotools git-r3
+ # x11-misc-util/macros only required on live ebuilds
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/app/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXcomposite
+ x11-libs/libXext
+"
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --disable-selective-werror
+ )
+
+ econf "${econfargs[@]}"
+}