summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZetok Zalbavar <zetok@openmailbox.org>2016-04-24 14:46:08 +0100
committerSam Jorna <wraeth@gentoo.org>2016-04-25 20:07:30 +1000
commit1fd75d5496f7066f14867eeb2e8c5f336cf678b0 (patch)
treece957d6f878ae2977492c85bca3caf58b03ac8db
parentsys-apps/ipmiutil: Removed old. (diff)
downloadgentoo-1fd75d5496f7066f14867eeb2e8c5f336cf678b0.tar.gz
gentoo-1fd75d5496f7066f14867eeb2e8c5f336cf678b0.tar.bz2
gentoo-1fd75d5496f7066f14867eeb2e8c5f336cf678b0.zip
net-im/qtox: add ebuild for v1.4.0 release
Signed-off-by: Sam Jorna <wraeth@gentoo.org>
-rw-r--r--net-im/qtox/Manifest1
-rw-r--r--net-im/qtox/qtox-1.4.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/net-im/qtox/Manifest b/net-im/qtox/Manifest
index 6c4da9702c36..5e8724cc0580 100644
--- a/net-im/qtox/Manifest
+++ b/net-im/qtox/Manifest
@@ -1 +1,2 @@
DIST qtox-1.3.0.tar.gz 4679256 SHA256 a2d1483a9aa6e99684853733a0a0a04c8cde168a775b9d2bdab94771fd82bc0a SHA512 9147e9f6c80098a6d1c3d9deaf92d5ae2a62894f0628b058e59a66616873aebbca8a1ba04c0436a1b2793ae766a2ba9056a832be1550b47e1799de24216f19e8 WHIRLPOOL 646eb1bb940408d1d9c7bfddf43ce66898b238158d0f0bb49896ec4899e3d540bae30ee968969bea544b529d6b8279d0017262c4a9a6e5c50d43b35da745eb2d
+DIST qtox-1.4.0.tar.gz 3021956 SHA256 f869aafddb597286dc03b828b48e2560a97983f180914c396fdcf2f1ca07ae79 SHA512 4c93e90ec20e8c9289f5be628f6543d356c99f59d72e735814ba2640b257fbb78f18a9dbd42070a5cfb7fded492906f07cc678d1ae737ac795da689b3e6abe2d WHIRLPOOL 68991d933427be17b6757010d03fda8647c3e3c448fe44a4dad812b9636802f9dc8667b76824d6b867f514e61da202a52d9ea2c4117cc3cda833b82301589f11
diff --git a/net-im/qtox/qtox-1.4.0.ebuild b/net-im/qtox/qtox-1.4.0.ebuild
new file mode 100644
index 000000000000..9583cfcb4cfd
--- /dev/null
+++ b/net-im/qtox/qtox-1.4.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qmake-utils
+
+DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
+HOMEPAGE="https://github.com/tux3/qtox"
+SRC_URI="https://github.com/tux3/qTox/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk X"
+
+# needed, since tarball provided by github extracts to `qTox`
+S="${WORKDIR}/qTox-${PV}"
+
+RDEPEND="
+ dev-db/sqlcipher
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[gif,jpeg,png,xcb]
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtxml:5
+ media-gfx/qrencode
+ media-libs/openal
+ >=media-video/ffmpeg-2.6.3[webp,v4l]
+ gtk? ( dev-libs/atk
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf[X]
+ x11-libs/gtk+:2
+ x11-libs/cairo[X]
+ x11-libs/pango[X] )
+ net-libs/tox[av]
+ virtual/pkgconfig
+ X? ( x11-libs/libX11
+ x11-libs/libXScrnSaver )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(tc-getCXX) == *g++ ]] ; then
+ if [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 8 || $(gcc-major-version) -lt 4 ]] ; then
+ eerror "You need at least sys-devel/gcc-4.8.3"
+ die "You need at least sys-devel/gcc-4.8.3"
+ fi
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
+ use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
+ # filter_audio is disabled since it's not available in Gentoo, and
+ # support for it in qTox at the present is ~broken anyway
+ eqmake5 \
+ PREFIX="${D}/usr" \
+ GIT_DESCRIBE="${PV}" \
+ DISABLE_FILTER_AUDIO=YES \
+ ${NO_GTK_SUPPORT} \
+ ${NO_X_SUPPORT}
+}