summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-06 19:50:34 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-06 23:46:59 +0100
commit21a6ee18b9bd70f4f008604f1fcac95c15746cbf (patch)
treebb7a1f1136d6068efaf76e6a9e0d1ca45f831f66
parentx11-misc/wdm: EAPI bump 2 -> 6, fix #554672 (diff)
downloadgentoo-21a6ee18b9bd70f4f008604f1fcac95c15746cbf.tar.gz
gentoo-21a6ee18b9bd70f4f008604f1fcac95c15746cbf.tar.bz2
gentoo-21a6ee18b9bd70f4f008604f1fcac95c15746cbf.zip
x11-misc/xdesktopwaves: EAPI bump 2 -> 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3853
-rw-r--r--x11-misc/xdesktopwaves/xdesktopwaves-1.3-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/xdesktopwaves/xdesktopwaves-1.3-r2.ebuild b/x11-misc/xdesktopwaves/xdesktopwaves-1.3-r2.ebuild
new file mode 100644
index 000000000000..c4a5b067cdb5
--- /dev/null
+++ b/x11-misc/xdesktopwaves/xdesktopwaves-1.3-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A cellular automata setting the background of your X Windows desktop under water"
+HOMEPAGE="http://xdesktopwaves.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+RDEPEND="x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ tc-export CC
+ emake
+ emake -C xdwapi
+}
+
+src_install() {
+ dobin xdesktopwaves xdwapi/xdwapidemo
+ doman xdesktopwaves.1
+ insinto /usr/share/pixmaps
+ doins xdesktopwaves.xpm
+ make_desktop_entry xdesktopwaves
+ einstalldocs
+}
+
+pkg_preinst() {
+ elog "To see what xdesktopwaves is able to do, start it by running"
+ elog "'xdesktopwaves' and then run 'xdwapidemo'. You should see the"
+ elog "supported effects on your desktop"
+}