summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-08-25 07:29:03 +0200
committerHans de Graaff <graaff@gentoo.org>2017-08-25 07:29:03 +0200
commit227e5bf6246dd7736d6466b90486c90aecf6c22c (patch)
tree0e07df2c3ac3cbbfaefd1a9dc8e9d0969db6c249
parentdev-ruby/right_http_connection: stable on amd64 (diff)
downloadgentoo-227e5bf6246dd7736d6466b90486c90aecf6c22c.tar.gz
gentoo-227e5bf6246dd7736d6466b90486c90aecf6c22c.tar.bz2
gentoo-227e5bf6246dd7736d6466b90486c90aecf6c22c.zip
dev-ruby/rbpdf: cleanup
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-ruby/rbpdf/Manifest2
-rw-r--r--dev-ruby/rbpdf/rbpdf-1.19.0.ebuild50
-rw-r--r--dev-ruby/rbpdf/rbpdf-1.19.1.ebuild50
3 files changed, 0 insertions, 102 deletions
diff --git a/dev-ruby/rbpdf/Manifest b/dev-ruby/rbpdf/Manifest
index 865179fc0627..a21835f385d2 100644
--- a/dev-ruby/rbpdf/Manifest
+++ b/dev-ruby/rbpdf/Manifest
@@ -1,3 +1 @@
-DIST rbpdf-1.19.0.gem 291840 SHA256 6fb408bda05c81f27af4a73abd13a20de8b485a6b2752502645cf3d2cb9eb89c SHA512 7c83334bd0069e3a5ebaa8d7037bb7eca0652df6a72afed0d1fb594fa2359830801ae59162df69ee1766bdbf39fe9b0e960d3b8d7a1eb6a7a63cf5b27dfb9dae WHIRLPOOL 09ce985446f9e08119cf81b0891c27b3bbd2c59ddf8b5500014634f901ab580d8c23ca56eb54016f55d300d9e63cbdb73b8e916655a0035067786aca3e336569
-DIST rbpdf-1.19.1.gem 524800 SHA256 405c47ab1fe0fdfa7c80c2d49a07e32fd4fefd6e65d0febbd381caa718203821 SHA512 d6b186cd9b66833e9ebad73f4109b748cdfdd16ea50c9df7a8eab2709f20fbcfcedbcc1decd14c96c4a6c91f4f387063553200e2a744cea8b76281474d83cb20 WHIRLPOOL 5981867beb4db096eacd397cc409bc4edd28127d0a19ca77e0abbc98118211d116d04c729d8bda787f69358ef16bcba0e6b87e1e4a7718e01960687bcd71c8d1
DIST rbpdf-1.19.2.gem 524800 SHA256 9195daf16f92c57b4ba45e77fb435101274c8bbd770e9f933f0dcacc5aca5373 SHA512 fcb27d7b4643e35ccffa13ab34221f45c744ca323f2ac497301d63d5c8a54367b67e8769f6e2f0cff7744520ececfef235769d895a9cff2a2f0b7376bc3ff95f WHIRLPOOL de5b5233765460effad2ea2d2fcad7b1354e1b6917c1529b8f4341390e3def18051f0a4eed77be386a690acf30583e114c5fbc5d1fa11592df9579eb99ff75e6
diff --git a/dev-ruby/rbpdf/rbpdf-1.19.0.ebuild b/dev-ruby/rbpdf/rbpdf-1.19.0.ebuild
deleted file mode 100644
index 5e89123d2df1..000000000000
--- a/dev-ruby/rbpdf/rbpdf-1.19.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby20 ruby21 ruby22"
-
-# Avoid the complexity of the "rake" recipe and run the tests manually.
-RUBY_FAKEGEM_RECIPE_TEST=none
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby on Rails RBPDF plugin"
-HOMEPAGE="https://github.com/naitoh/rbpdf"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-ruby_add_bdepend "test? ( >=dev-ruby/test-unit-3 )"
-ruby_add_rdepend "dev-ruby/actionview:*
- dev-ruby/htmlentities
- dev-ruby/rbpdf-font"
-
-all_ruby_prepare() {
- default
-
- # This test is enabled automagically in the presence of rmagick, and
- # then fails.
- rm -f test/rbpdf_image_rmagick_test.rb \
- || die "failed to remove rmagick tests"
-
- # Loosen very restrictive htmlentities dependency
- sed -i -e '/htmlentities/ s/=/>=/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- local cmd='gem "test-unit", ">= 3.0"'
- cmd+=' and '
- cmd+='require "test/unit"'
- cmd+=' and '
- cmd+='Dir["test/rbpdf_*.rb"].each{|f| require("./" + f)}'
- ${RUBY} -Ilib:.:test -e "${cmd}" || die "test suite failed"
-}
diff --git a/dev-ruby/rbpdf/rbpdf-1.19.1.ebuild b/dev-ruby/rbpdf/rbpdf-1.19.1.ebuild
deleted file mode 100644
index 4bd79ea745a1..000000000000
--- a/dev-ruby/rbpdf/rbpdf-1.19.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby21 ruby22 ruby23"
-
-# Avoid the complexity of the "rake" recipe and run the tests manually.
-RUBY_FAKEGEM_RECIPE_TEST=none
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby on Rails RBPDF plugin"
-HOMEPAGE="https://github.com/naitoh/rbpdf"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-ruby_add_bdepend "test? ( >=dev-ruby/test-unit-3 )"
-ruby_add_rdepend "dev-ruby/actionview:*
- dev-ruby/htmlentities
- =dev-ruby/rbpdf-font-1.19*"
-
-all_ruby_prepare() {
- default
-
- # This test is enabled automagically in the presence of rmagick, and
- # then fails.
- rm -f test/rbpdf_image_rmagick_test.rb \
- || die "failed to remove rmagick tests"
-
- # Loosen very restrictive htmlentities dependency
- sed -i -e '/htmlentities/ s/=/>=/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- local cmd='gem "test-unit", ">= 3.0"'
- cmd+=' and '
- cmd+='require "test/unit"'
- cmd+=' and '
- cmd+='Dir["test/rbpdf_*.rb"].each{|f| require("./" + f)}'
- ${RUBY} -Ilib:.:test -e "${cmd}" || die "test suite failed"
-}