summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-09-27 20:48:19 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-27 20:48:37 +0200
commit244899e9b0492eb521a4943e974e5a2e6540dbeb (patch)
tree470c4817266cf46337c89cd8b1e9079a9c16e559
parentdev-python/brython: clean up old. (diff)
downloadgentoo-244899e9b0492eb521a4943e974e5a2e6540dbeb.tar.gz
gentoo-244899e9b0492eb521a4943e974e5a2e6540dbeb.tar.bz2
gentoo-244899e9b0492eb521a4943e974e5a2e6540dbeb.zip
dev-python/brython: convert ebuild to python-single-r1.
Package-Manager: Portage-2.3.8, Repoman-2.3.1
-rw-r--r--dev-python/brython/brython-3.3.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/brython/brython-3.3.2-r1.ebuild b/dev-python/brython/brython-3.3.2-r1.ebuild
new file mode 100644
index 000000000000..ca62031b60cc
--- /dev/null
+++ b/dev-python/brython/brython-3.3.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit webapp python-single-r1
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}