summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-11 17:01:26 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-11 17:02:14 +0100
commit26cba9895716c8dd9462241105d96c440678ecff (patch)
tree685486a1bee2426f826a4b307f1aaaf6892281c5
parentapp-office/impressive: Clean old up (diff)
downloadgentoo-26cba9895716c8dd9462241105d96c440678ecff.tar.gz
gentoo-26cba9895716c8dd9462241105d96c440678ecff.tar.bz2
gentoo-26cba9895716c8dd9462241105d96c440678ecff.zip
net-libs/libbtbb: Clean the old version up
Remove the old version that is impossible to install due to requirement on net-analyzer/wireshark versions that are no longer present in ::gentoo.
-rw-r--r--net-libs/libbtbb/Manifest1
-rw-r--r--net-libs/libbtbb/libbtbb-2015.10.1.ebuild132
2 files changed, 0 insertions, 133 deletions
diff --git a/net-libs/libbtbb/Manifest b/net-libs/libbtbb/Manifest
index c62b1b24f01c..faa70bb24b2d 100644
--- a/net-libs/libbtbb/Manifest
+++ b/net-libs/libbtbb/Manifest
@@ -1,2 +1 @@
-DIST libbtbb-2015-10-R1.tar.gz 221859 BLAKE2B ee24849f85b4ec1d0eac0c6779bb30074e7544dd07eea4591db5503322f4ce238bd5817900665def51b36b533d360ca7b0d2cf1464643d4a25a897fb1fb5fa86 SHA512 550d793326cfb4d31ed00d46faf3521ccafc133614f866961ba6226dff41d3deda428b45f01178e0dea7925635a64e843f0510049408c3f299ad427f2c0832ac
DIST libbtbb-2017-03-R2.tar.gz 303689 BLAKE2B d36cf5329fb31cd50f64e3a9b625ebca8bf198794073480baa4f64935f4bef183e4c11f0844cd31df943da98c778bdea807fbd91676c23a3a2f830af5e7a185f SHA512 bb7b58a33198fd64fba5f0254cfbb71120c70476d594a7aaf82c77f770d1a6e89b4571f42d3d15c1d93d5246c9145c33ba8724a5ee5ad84e96f748d9f32275b5
diff --git a/net-libs/libbtbb/libbtbb-2015.10.1.ebuild b/net-libs/libbtbb/libbtbb-2015.10.1.ebuild
deleted file mode 100644
index 7734344c353f..000000000000
--- a/net-libs/libbtbb/libbtbb-2015.10.1.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit multilib cmake-utils
-
-DESCRIPTION="A library to decode Bluetooth baseband packets"
-HOMEPAGE="http://libbtbb.sourceforge.net/"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/greatscottgadgets/libbtbb.git"
- inherit git-r3
- KEYWORDS=""
-else
- MY_PV=${PV/\./-}
- MY_PV=${MY_PV/./-R}
- S=${WORKDIR}/${PN}-${MY_PV}
- SRC_URI="https://github.com/greatscottgadgets/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0/${PV}"
-IUSE="+pcap +wireshark-plugins"
-
-RDEPEND="
- pcap? ( net-libs/libpcap )
- wireshark-plugins? (
- >=net-analyzer/wireshark-1.8.3-r1:=
- !>net-analyzer/wireshark-1.98
- )
-"
-DEPEND="${RDEPEND}
- wireshark-plugins? ( dev-libs/glib
- virtual/pkgconfig )"
-
-get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
-
-which_plugins() {
- if has_version '>=net-analyzer/wireshark-1.12.0'; then
- plugins="btbb btbredr"
- elif has_version '<net-analyzer/wireshark-1.12.0'; then
- plugins="btbb btle btsm"
- fi
-}
-
-src_prepare(){
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake-utils_src_prepare
-
- if use wireshark-plugins; then
- which_plugins
- for i in ${plugins}
- do
- sed -i 's#column_info#packet#' wireshark/plugins/${i}/cmake/FindWireshark.cmake || die
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_prepare
- done
- fi
-}
-
-src_configure() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- local mycmakeargs=(
- -DDISABLE_PYTHON=true
- -DPACKAGE_MANAGER=true
- $(cmake-utils_use pcap PCAPDUMP)
- $(cmake-utils_use pcap USE_PCAP)
- )
- cmake-utils_src_configure
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- BUILD_DIR="${WORKDIR}"/${i}_build
- local mycmakeargs=(
- -DCMAKE_INSTALL_LIBDIR="/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)"
- )
- cmake-utils_src_configure
- done
- fi
-}
-
-src_compile(){
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake-utils_src_compile
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_compile
- done
- fi
-}
-
-src_test(){
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake-utils_src_test
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_test
- done
- fi
-}
-
-src_install(){
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake-utils_src_install
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake-utils_src_install
- done
- fi
-}