summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-04-06 23:21:38 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-04-06 23:22:53 -0500
commit286329202f7fea25dd15832b75707df420e32e9b (patch)
tree160bd48211be654f48cd00ec4ceb8982cdeaca36
parentsci-libs/tensorflow-estimator: add rules_cc distfile for bazel 2.0 (diff)
downloadgentoo-286329202f7fea25dd15832b75707df420e32e9b.tar.gz
gentoo-286329202f7fea25dd15832b75707df420e32e9b.tar.bz2
gentoo-286329202f7fea25dd15832b75707df420e32e9b.zip
Revert "sci-libs/adolc: drop old"
This reverts commit c124472bf2e70c44ddcb5f4bdbe67ae16777c193. Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--sci-libs/adolc/Manifest1
-rw-r--r--sci-libs/adolc/adolc-2.4.1.ebuild38
-rw-r--r--sci-libs/adolc/files/adolc-2.4.0-no-colpack.patch24
3 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/adolc/Manifest b/sci-libs/adolc/Manifest
index 87f66d5bf1f8..e037c72c745b 100644
--- a/sci-libs/adolc/Manifest
+++ b/sci-libs/adolc/Manifest
@@ -1,2 +1,3 @@
+DIST ADOL-C-2.4.1.tgz 2210414 BLAKE2B f9b1fd7f0e619d811b29e077e436697dc8b5a388568d73b2db602e57f97cbb690a5b47a55c722ae45cc28698dd19949eddb9d02e11c87383191e217f012519bb SHA512 5e5135ca587d159510bf77338fdff3d324f4d32c4ec6f8cf64ddc92253b427b8ee26a30bc1d83fe18121bbfdc7454c3536f58849c0c335e1b240e39d46acdccc
DIST ADOL-C-2.6.3.tgz 2416928 BLAKE2B 74e575a1a919bc2787be0c29deaac4b503c077cb06efdba3f2382f21abf1ed53e8cb5f41729dc39f9188e44460fa137a09cffdb296b5f92131153795f36fa83a SHA512 e3c44b1f8ab5211a8a3c3163124e35b6d1e9551672ab4944d983dd3117f609d512c1b08c61e535dc4d50089295ee565bec07aaca67aa88b57b17bc3906573262
DIST adolc-2.7.2.tar.gz 2447479 BLAKE2B 0f871ce1dcb50bb14684e45e265cf45807f514dd3ca0dbaaedede2c7117d34cc5a34b0096a34c8ec37023e50aec7fd4be6561819d6297771e7f7fcaa7ba0e507 SHA512 b896650077367fd7388a6c5a40e5d8bb3f19af9e3bc5b067fd1d9a769809b77ccdfb5ef11ef481ab791c0f040401aaed0053cba55d4c2a3383c0d056122280f6
diff --git a/sci-libs/adolc/adolc-2.4.1.ebuild b/sci-libs/adolc/adolc-2.4.1.ebuild
new file mode 100644
index 000000000000..d8eda2e65133
--- /dev/null
+++ b/sci-libs/adolc/adolc-2.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+inherit autotools-utils toolchain-funcs
+
+MYPN=ADOL-C
+
+DESCRIPTION="Automatic differentiation system for C/C++"
+HOMEPAGE="https://projects.coin-or.org/ADOL-C/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="|| ( EPL-1.0 GPL-2 )"
+SLOT="0/1"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="sparse static-libs"
+
+RDEPEND="sparse? ( sci-libs/colpack )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}-${PV}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.4.0-no-colpack.patch )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable sparse)
+ $(use_with sparse colpack "${EPREFIX}"/usr)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
diff --git a/sci-libs/adolc/files/adolc-2.4.0-no-colpack.patch b/sci-libs/adolc/files/adolc-2.4.0-no-colpack.patch
new file mode 100644
index 000000000000..e3b5a4a2ca5f
--- /dev/null
+++ b/sci-libs/adolc/files/adolc-2.4.0-no-colpack.patch
@@ -0,0 +1,24 @@
+do not test colpack when user says no even when it is installed
+
+--- configure.ac.orig 2012-07-19 13:04:37.426461811 -0700
++++ configure.ac 2012-07-19 13:06:06.477916144 -0700
+@@ -281,7 +281,7 @@
+ COLPACK_LIBDIR=""
+ COLPACK_LIBS="-lColPack"
+ ])
+-
++if test x$colpack != xno; then
+ AC_LANG_PUSH([C++])
+ save_CPPFLAGS="$CPPFLAGS"
+ save_LIBS="$LIBS"
+@@ -301,7 +301,9 @@
+ CPPFLAGS="$save_CPPFLAGS"
+ LIBS="$save_LIBS"
+ AC_LANG_POP([C++])
+-
++else
++ have_colpack=no
++fi
+ AM_CONDITIONAL(HAVE_LIBCOLPACK,[test x$have_colpack = xyes])
+ if test x$have_colpack = xyes; then
+ sparse=yes