summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-01-23 17:57:59 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-01-23 17:58:11 +0000
commit28cda407f2bbad10404e87168afa36c94273ac09 (patch)
tree003dd9e7ea4830c4d0a606def778fd8ac5ac925d
parentmedia-sound/supercollider: Drop 3.11.0-r1 (diff)
downloadgentoo-28cda407f2bbad10404e87168afa36c94273ac09.tar.gz
gentoo-28cda407f2bbad10404e87168afa36c94273ac09.tar.bz2
gentoo-28cda407f2bbad10404e87168afa36c94273ac09.zip
sys-devel/gcc-config: bump up to 2.3.3
Single new change: - gcc-config: Do not call 'python' directly. Reported-by: John Helmert III (ajak) Closes: https://bugs.gentoo.org/766597 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-devel/gcc-config/Manifest1
-rw-r--r--sys-devel/gcc-config/gcc-config-2.3.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sys-devel/gcc-config/Manifest b/sys-devel/gcc-config/Manifest
index 1622690ac13c..38fb58fecf89 100644
--- a/sys-devel/gcc-config/Manifest
+++ b/sys-devel/gcc-config/Manifest
@@ -1 +1,2 @@
DIST gcc-config-2.3.2.tar.xz 17444 BLAKE2B c66fd121770dddcb27033be228de691f766f1acd9ada9580ae96dc12f6fbd0cd823e6656dc9b0515d498305b10d72f9cd87cf69388791971e9eac1a20e3f97c9 SHA512 31327d9abd26fdadaaf25a63568fd860ae25030b4a99dcbf0424f2d8fb14e61f041e681eea90c781a3f4e5401e3a7ba3299b1260ceb6e51bda5bef24f65dcacc
+DIST gcc-config-2.3.3.tar.xz 17452 BLAKE2B fb77e2a2ea3d57142e6784d985364f3c0c82c149af10ac0a6490b3f4acceb3cd86e9d25168a60c532dd2bfce300a12a13cfc0eb290bf8c9457e43b9acf247328 SHA512 110af5a15e34c41f8f0568f20215bd4b0db2ffd2e65a4c3e7c3a6695c0de574e85478582cd65b627591ee754cd7f28c01ab8f3c3a101ed00c2b42fedab58a08a
diff --git a/sys-devel/gcc-config/gcc-config-2.3.3.ebuild b/sys-devel/gcc-config/gcc-config-2.3.3.ebuild
new file mode 100644
index 000000000000..33b842037c49
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-2.3.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gcc-config.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Utility to manage compilers"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gcc-config.git/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+cc-wrappers +native-symlinks"
+
+RDEPEND=">=sys-apps/gentoo-functions-0.10"
+
+_emake() {
+ emake \
+ PV="${PVR}" \
+ SUBLIBDIR="$(get_libdir)" \
+ USE_CC_WRAPPERS="$(usex cc-wrappers)" \
+ USE_NATIVE_LINKS="$(usex native-symlinks)" \
+ TOOLCHAIN_PREFIX="${CHOST}-" \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ # Do we have a valid multi ver setup ?
+ local x
+ for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
+ gcc-config ${x}
+ done
+
+ # USE flag change can add or delete files in /usr/bin worth recaching
+ if [[ ! ${ROOT} && -f ${EPREFIX}/usr/share/eselect/modules/compiler-shadow.eselect ]] ; then
+ eselect compiler-shadow update all
+ fi
+}