summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-02-11 21:51:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-11 23:46:35 +0100
commit2b19e627a214e957f34c26481f75cdc5520daad0 (patch)
tree221c05431fc3c2082937d65a84251dc384d4215c
parentx11-libs/qtermwidget: remove old version 0.9.0 (diff)
downloadgentoo-2b19e627a214e957f34c26481f75cdc5520daad0.tar.gz
gentoo-2b19e627a214e957f34c26481f75cdc5520daad0.tar.bz2
gentoo-2b19e627a214e957f34c26481f75cdc5520daad0.zip
x11-misc/qps: add version 2.0.0
Closes: https://bugs.gentoo.org/701356 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--x11-misc/qps/Manifest1
-rw-r--r--x11-misc/qps/qps-2.0.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/qps/Manifest b/x11-misc/qps/Manifest
index 100aa3ac56c8..366df74b4326 100644
--- a/x11-misc/qps/Manifest
+++ b/x11-misc/qps/Manifest
@@ -1 +1,2 @@
DIST qps-1.10.20.tar.xz 209588 BLAKE2B abf50904a97e9d2f5755bfc25509266de9c4b5a941a1010f93f475f02e8801b970ba112b01727e076c7b232cf23f50f6b8f7d2fe7acf2d8b273686f6a92404f3 SHA512 407130ac12f1e68da3e22543634d101c7a8353363ff1d9c6edbf98ce5d48f149aa5d937985f00109b40bd3cdb0b9a8e9745e845dd921be4aaf119022632bb9ef
+DIST qps-2.0.0.tar.xz 211452 BLAKE2B 9b8501f3e57939b33ea54daf58d84cf37b6b66a0c4a32d546691898a82f19b747eba4eef77db6f07ca917da83fabfbee0f7ad9cd146b92e160c886d5f1905a02 SHA512 b5c3d194e97ac61ede43e29f4f12e3775ee8afabb1c1c344d068ea0af85fc8a574667cb6c4b801af620e81da1648b0618e31df7c0d5701cf47625482e8528019
diff --git a/x11-misc/qps/qps-2.0.0.ebuild b/x11-misc/qps/qps-2.0.0.ebuild
new file mode 100644
index 000000000000..62d707ac4e11
--- /dev/null
+++ b/x11-misc/qps/qps-2.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Visual process manager - Qt version of ps/top"
+HOMEPAGE="https://lxqt.org/"
+SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1+ QPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}