summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-11-11 07:39:43 +0100
committerHans de Graaff <graaff@gentoo.org>2018-11-11 07:39:43 +0100
commit2c29537c0d6271614ce292cb3e3747a04fd8057a (patch)
treeea5349873353b4dfdad1f12219e664f025963d5b
parentdev-util/howdoi: version bump 1.1.14 (diff)
downloadgentoo-2c29537c0d6271614ce292cb3e3747a04fd8057a.tar.gz
gentoo-2c29537c0d6271614ce292cb3e3747a04fd8057a.tar.bz2
gentoo-2c29537c0d6271614ce292cb3e3747a04fd8057a.zip
dev-ruby/regexp_property_values: initial import of 0.3.4
New dependency for dev-ruby/regexp_parser. Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-ruby/regexp_property_values/Manifest1
-rw-r--r--dev-ruby/regexp_property_values/metadata.xml8
-rw-r--r--dev-ruby/regexp_property_values/regexp_property_values-0.3.4.ebuild43
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/regexp_property_values/Manifest b/dev-ruby/regexp_property_values/Manifest
new file mode 100644
index 000000000000..efb4558098ea
--- /dev/null
+++ b/dev-ruby/regexp_property_values/Manifest
@@ -0,0 +1 @@
+DIST regexp_property_values-0.3.4.tar.gz 11273 BLAKE2B a52ab11676b58a752741240912da5fa312661a583dd74a4321f8184fef2864c74e0d5f709cb68e3ce64a3e19e9320305e80bf7614a40142c4855ccec1c40b5a5 SHA512 01ca50f831bf3364e38559e06cb54faef59fdb0b995a6bfa0aaa3943591d98f97939a47911bf8b075b34b3c401b5de51e42a71088400112ee8afd8d39f164465
diff --git a/dev-ruby/regexp_property_values/metadata.xml b/dev-ruby/regexp_property_values/metadata.xml
new file mode 100644
index 000000000000..28ab0c15f206
--- /dev/null
+++ b/dev-ruby/regexp_property_values/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/regexp_property_values/regexp_property_values-0.3.4.ebuild b/dev-ruby/regexp_property_values/regexp_property_values-0.3.4.ebuild
new file mode 100644
index 000000000000..84592cb36a2a
--- /dev/null
+++ b/dev-ruby/regexp_property_values/regexp_property_values-0.3.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="See which property values are supported by the regular expression engine"
+HOMEPAGE="https://github.com/janosch-x/regexp_property_values"
+SRC_URI="https://github.com/janosch-x/regexp_property_values/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid dependency on character_set which would lead to circular
+ # dependencies.
+ sed -i -e '/returns a CharacterSet/askip "gentoo circular dependencies"' spec/regexp_property_values/extension_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/regexp_property_values extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/regexp_property_values V=1
+ cp ext/regexp_property_values/regexp_property_values.so lib/regexp_property_values/ || die
+}