summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-10-27 14:13:24 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-10-27 14:13:37 +0100
commit2c948b7b0c4666e0760eb7833f92abb3a6e884a8 (patch)
treef16a9b92f90e553593856d0bcfdccb70b98866dd
parentsci-chemistry/gromacs: Version bump (diff)
downloadgentoo-2c948b7b0c4666e0760eb7833f92abb3a6e884a8.tar.gz
gentoo-2c948b7b0c4666e0760eb7833f92abb3a6e884a8.tar.bz2
gentoo-2c948b7b0c4666e0760eb7833f92abb3a6e884a8.zip
games-emulation/dosbox-staging: 0.75.2 bump
Set -DNDEBUG preprocessor flag for release build Fix license (GPL-2+) in current ebuilds Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--games-emulation/dosbox-staging/Manifest1
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.75.1-r1.ebuild2
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.75.1-r2.ebuild2
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.75.2.ebuild49
4 files changed, 52 insertions, 2 deletions
diff --git a/games-emulation/dosbox-staging/Manifest b/games-emulation/dosbox-staging/Manifest
index 8e11b738031b..b6c0a4be8d99 100644
--- a/games-emulation/dosbox-staging/Manifest
+++ b/games-emulation/dosbox-staging/Manifest
@@ -1 +1,2 @@
DIST dosbox-staging-0.75.1.tar.gz 1806471 BLAKE2B 5f9f8038327eb46c2c2b5035ca8e2cc93660bb6ce1dfa9572bf67278f14455db723104c0ab4e90b805cc7dbf253f61528ad6a31edb574af57e106f613958aede SHA512 3e14354e4eb697514c4348af2e73e9f2fb84cc3796b5cfea37faac355bd93a54b0f9c717bf0ab75d824cf34e3ee0d40546e2bbf80bc924a37bd8f981f054e4e9
+DIST dosbox-staging-0.75.2.tar.gz 1816233 BLAKE2B 0cb3224a1fe0e01e5069b78c91191f33b6d84dfb21b00ed8cd832225e68e5f66e841506bc7c887da462727b931a6c72b84dbf5e48e4dde21dbf62ffa3da4edc6 SHA512 2988b2cc44d041193d900efc4c6fa516aca6246e51c1dece9b207bd3549a8c76c5bcb2f3f5a90da6bb2b573663bddd0020274f17130548aef9cef1f4adf79220
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.75.1-r1.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.75.1-r1.ebuild
index dbebde3b22e9..afdf9f7951fe 100644
--- a/games-emulation/dosbox-staging/dosbox-staging-0.75.1-r1.ebuild
+++ b/games-emulation/dosbox-staging/dosbox-staging-0.75.1-r1.ebuild
@@ -8,7 +8,7 @@ DESCRIPTION="Modernized DOSBox soft-fork"
HOMEPAGE="https://dosbox-staging.github.io/"
SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="alsa debug dynrec network opengl opus"
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.75.1-r2.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.75.1-r2.ebuild
index 12e1e2970308..bdedc780583a 100644
--- a/games-emulation/dosbox-staging/dosbox-staging-0.75.1-r2.ebuild
+++ b/games-emulation/dosbox-staging/dosbox-staging-0.75.1-r2.ebuild
@@ -8,7 +8,7 @@ DESCRIPTION="Modernized DOSBox soft-fork"
HOMEPAGE="https://dosbox-staging.github.io/"
SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="alsa debug dynrec network opengl opus"
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.75.2.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.75.2.ebuild
new file mode 100644
index 000000000000..75de6e5a03a1
--- /dev/null
+++ b/games-emulation/dosbox-staging/dosbox-staging-0.75.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop flag-o-matic xdg
+
+DESCRIPTION="Modernized DOSBox soft-fork"
+HOMEPAGE="https://dosbox-staging.github.io/"
+SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug dynrec network opengl opus"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ debug? ( sys-libs/ncurses:0= )
+ network? ( media-libs/sdl2-net )
+ opengl? ( virtual/opengl )
+ opus? ( media-libs/opusfile )
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,opengl?,video,X]
+ sys-libs/zlib
+ !games-emulation/dosbox"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use debug || append-cppflags -DNDEBUG
+ econf \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable debug) \
+ $(use_enable !dynrec dynamic-x86) \
+ $(use_enable dynrec) \
+ $(use_enable network) \
+ $(use_enable opengl) \
+ $(use_enable opus opus-cdda)
+}
+
+src_install() {
+ default
+ doicon -s scalable contrib/icons/${PN}.svg
+ domenu contrib/linux/dosbox-staging.desktop
+}