summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-01-24 20:26:12 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-01-24 20:32:24 +0000
commit317b6668b829f623fe4cc2deccba7dbbaedf6627 (patch)
tree194d7ddc53892a91f1bfa31b56c29c1ffbbf40d2
parentvirtual/jre: It's 2016, let's use EAPI 6 and SLOT dependencies (diff)
downloadgentoo-317b6668b829f623fe4cc2deccba7dbbaedf6627.tar.gz
gentoo-317b6668b829f623fe4cc2deccba7dbbaedf6627.tar.bz2
gentoo-317b6668b829f623fe4cc2deccba7dbbaedf6627.zip
virtual/jdk: It's 2016, let's use EAPI 6 and SLOT dependencies
Ignoring 1.6 because it's about to die. Package-Manager: portage-2.2.27
-rw-r--r--virtual/jdk/jdk-1.7.0-r1.ebuild16
-rw-r--r--virtual/jdk/jdk-1.8.0-r1.ebuild (renamed from virtual/jdk/jdk-1.8.0.ebuild)8
2 files changed, 19 insertions, 5 deletions
diff --git a/virtual/jdk/jdk-1.7.0-r1.ebuild b/virtual/jdk/jdk-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..2ab126fd721b
--- /dev/null
+++ b/virtual/jdk/jdk-1.7.0-r1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+DESCRIPTION="Virtual for Java Development Kit (JDK)"
+SLOT="1.7"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="|| (
+ dev-java/icedtea-bin:7
+ dev-java/icedtea:7
+ dev-java/oracle-jdk-bin:1.7
+ dev-java/soylatte-jdk-bin:1.7
+ )"
diff --git a/virtual/jdk/jdk-1.8.0.ebuild b/virtual/jdk/jdk-1.8.0-r1.ebuild
index 73c1d4139080..03f73aec9c12 100644
--- a/virtual/jdk/jdk-1.8.0.ebuild
+++ b/virtual/jdk/jdk-1.8.0-r1.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="6"
DESCRIPTION="Virtual for Java Development Kit (JDK)"
SLOT="1.8"
-# TODO: Temporarily dropped ~sparc-solaris and ~x86-solaris as oracle-jdk-bin
-# no longer provides them. Also temporarily dropped ~ia64.
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
-RDEPEND="=dev-java/oracle-jdk-bin-1.8.0*"
+RDEPEND="dev-java/oracle-jdk-bin:1.8"