summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 23:12:47 +0100
committerSam James <sam@gentoo.org>2021-04-19 23:41:29 +0100
commit318a8ff7020ca0ecde19feaed7c302a2bd24df69 (patch)
tree12c7303e494026c8943c12f7f510da1b387dcdf0
parentapp-vim/taglist: port to EAPI 7 (diff)
downloadgentoo-318a8ff7020ca0ecde19feaed7c302a2bd24df69.tar.gz
gentoo-318a8ff7020ca0ecde19feaed7c302a2bd24df69.tar.bz2
gentoo-318a8ff7020ca0ecde19feaed7c302a2bd24df69.zip
x11-themes/gartoon-redux: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild28
1 files changed, 19 insertions, 9 deletions
diff --git a/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild b/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
index aeaa7890f999..9d96533afe71 100644
--- a/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
+++ b/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit epatch gnome2-utils
+EAPI=7
+
+inherit gnome2-utils
DESCRIPTION="A massively improved variant of the well-known Gartoon theme"
HOMEPAGE="https://gnome-look.org/content/show.php/?content=74841"
@@ -12,7 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="
+BDEPEND="
dev-lang/perl
dev-perl/Switch
gnome-base/librsvg
@@ -20,9 +21,9 @@ DEPEND="
RESTRICT="binchecks strip"
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.10-rsvg-convert.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10-rsvg-convert.patch
+)
src_configure() {
# perl script, not autotools based
@@ -40,6 +41,15 @@ src_install() {
dodoc AUTHORS changelog README TODO
}
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }
+pkg_preinst() {
+ gnome2_icon_savelist
+
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}