summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-01 19:55:31 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-01 20:04:30 +0100
commit31d4c89d5ee52e44554be844bc019094a1feebb1 (patch)
treee5269a7176d17d3b1e0431cec67af9b100a7dbfe
parentdev-python/wtf-peewee: Bump (diff)
downloadgentoo-31d4c89d5ee52e44554be844bc019094a1feebb1.tar.gz
gentoo-31d4c89d5ee52e44554be844bc019094a1feebb1.tar.bz2
gentoo-31d4c89d5ee52e44554be844bc019094a1feebb1.zip
dev-python/python-oembed: Bump
Package-Manager: portage-2.2.27
-rw-r--r--dev-python/python-oembed/Manifest1
-rw-r--r--dev-python/python-oembed/python-oembed-0.2.4.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-oembed/Manifest b/dev-python/python-oembed/Manifest
index 6608a3e75932..0983611b096e 100644
--- a/dev-python/python-oembed/Manifest
+++ b/dev-python/python-oembed/Manifest
@@ -1,2 +1,3 @@
DIST python-oembed-0.2.1.tar.gz 7809 SHA256 70ac9320a2548185dca71af48fff657d4b11e20840bba101a87405cda0e4e0af SHA512 27c3b3ad2ccddc864660d9f3de9c20f19417f9e3844a3ab36bbaf8364760104d8ca8d446fe4dbebf596fa9c88f284b51747bd801889e68424546dabd340b8278 WHIRLPOOL 32b62dd8222f018d71c6ef1b6a53bc618d1cfbd495b03a473c7202aa8cbc57054fe08b091328fe4897a1b6e765aac54c370fc80b1f413d6e8746746fbba6223a
DIST python-oembed-0.2.2.tar.gz 7858 SHA256 809208fe46d0e9b84cc8b2115e68e71022f530d47b2e4f11353c037c53d8b20f SHA512 ba1a6d9d317275099811be34e9f37009068e1f1e56bdb1091037030185129e36fbc50efcd64e1f7201ae24840745f7819433cc70c59e76baf1e42d627a7fe826 WHIRLPOOL d0ee3a10ae521767a20c831ed13993f1f4a11ee7614063ced28285943351ba2aefab4e61b37bdffa97b3c2bf2e36ddf0c3ade512ae807843653492a162354815
+DIST python-oembed-0.2.4.tar.gz 7981 SHA256 e0804ea3bd7ab8ec1460d139b7a92b6a9e4e3cddd83012dfe30cc67e314716ea SHA512 9eaae818e17fcfed2e53e7f730ff6837b3ec55bf977892dc05c79846b0afe6a3b6808e046ac8e41bfca587de07d1be40343d6b0df1a502418990e9bdb8d81abe WHIRLPOOL d705e84c8faf9174f302879e2620154c127762b53892fa9783203cba7e61b4681f3519cc30175b183f262a1bde7d148135bd7e5964dafed1fb16a5b0c11957fa
diff --git a/dev-python/python-oembed/python-oembed-0.2.4.ebuild b/dev-python/python-oembed/python-oembed-0.2.4.ebuild
new file mode 100644
index 000000000000..510d26a84804
--- /dev/null
+++ b/dev-python/python-oembed/python-oembed-0.2.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library that implements an OEmbed consumer"
+HOMEPAGE="https://pypi.python.org/pypi/python-oembed"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die "tests failed"
+}