summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-01 16:32:26 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-01 16:44:20 +0100
commit35a2a3ea05950687bec38ae26b83df0681c676e9 (patch)
tree975a98e1b95775150f90945062d2170f2862776f
parentdev-libs/ppl: add alpha keyword (diff)
downloadgentoo-35a2a3ea05950687bec38ae26b83df0681c676e9.tar.gz
gentoo-35a2a3ea05950687bec38ae26b83df0681c676e9.tar.bz2
gentoo-35a2a3ea05950687bec38ae26b83df0681c676e9.zip
dev-python/mimeparse: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/mimeparse/Manifest1
-rw-r--r--dev-python/mimeparse/mimeparse-1.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/mimeparse/Manifest b/dev-python/mimeparse/Manifest
index 70a660056337..451d25f7971c 100644
--- a/dev-python/mimeparse/Manifest
+++ b/dev-python/mimeparse/Manifest
@@ -1 +1,2 @@
DIST python-mimeparse-0.1.4.tar.gz 5228 SHA256 3c69a21e37e77f754e6fc09ebda70acd92c90d8a58f29a41cc0248351378ddc3 SHA512 c8eeb298773a0eb36512b1d9a46dfc85423c0dab10b85ed94284bf1bf8dba8c34aeccefd8b6a187434789d5a160ab5d4af81659dd1808ea02078cc2b168e10b3 WHIRLPOOL f83328743b16ae46263e05055d6400617b7858e11837ce892919e26a36348650122b78ee366125a1793b20fa71c641b3606bf834d2936f98dab65b89b740385b
+DIST python-mimeparse-1.5.tar.gz 5827 SHA256 9518ff1576d60e99f310116711beda6974f18caa3deb01c73d25bab409408878 SHA512 799b40c0128f22949869bc55f618b46f022bf937cd59be21343dab3d3d977cc24d84744dcbd23da4efb135e940a1373f064ec6e56e8bd4188fa54a3107d2718f WHIRLPOOL b9c9748c24ff931c2c3a2ae4da088818f9a7018be6450783c3ac0ff533e7292b23a5e94cff976b3209003a481240a5a4af65c7d6b81753b80e200b0fc5a0c03d
diff --git a/dev-python/mimeparse/mimeparse-1.5.ebuild b/dev-python/mimeparse/mimeparse-1.5.ebuild
new file mode 100644
index 000000000000..0d1ed5a0049b
--- /dev/null
+++ b/dev-python/mimeparse/mimeparse-1.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="python-${PN}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Basic functions for handling mime-types in python"
+HOMEPAGE="
+ https://code.google.com/p/mimeparse
+ https://github.com/dbtsai/python-mimeparse"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" mimeparse_test.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ if [[ ${EPYTHON} == pypy ]]; then
+ local pyver=2.7
+ elif [[ ${EPYTHON} == pypy3 ]]; then
+ local pyver=3.2
+ else
+ local pyver=${EPYTHON#python}
+ fi
+ python_export PYTHON_SITEDIR
+
+ # Previous versions were just called 'mimeparse'
+ ln -sf python_mimeparse-${PV}-py${pyver}.egg-info \
+ "${D%/}${PYTHON_SITEDIR}/mimeparse-${PV}-py${pyver}.egg-info" || die
+}