summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-01-08 09:45:08 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-01-08 09:54:33 +0100
commit35a8d6cd6d44358b986022dd781383c2680d2f75 (patch)
treec233530b5e4b5be8bac9f7929992f5a6bc1f9b62
parentdev-ros/rosconsole: Remove old (diff)
downloadgentoo-35a8d6cd6d44358b986022dd781383c2680d2f75.tar.gz
gentoo-35a8d6cd6d44358b986022dd781383c2680d2f75.tar.bz2
gentoo-35a8d6cd6d44358b986022dd781383c2680d2f75.zip
dev-ros/rosconsole: bump to 1.13.9
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/rosconsole/Manifest1
-rw-r--r--dev-ros/rosconsole/rosconsole-1.13.9.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ros/rosconsole/Manifest b/dev-ros/rosconsole/Manifest
index 3bc5076fdd59..1128ccdba987 100644
--- a/dev-ros/rosconsole/Manifest
+++ b/dev-ros/rosconsole/Manifest
@@ -1 +1,2 @@
DIST rosconsole-1.13.7.tar.gz 24202 BLAKE2B bee6d4a9a682fe045a233989373e8a283c26d85bd4d746c2363798cd61f168e368afef81872437363b55a44080e6c926b4f3fd9c66fa9e2bf078454a675336ea SHA512 e0e17641011de5a3b58ddc7ac984042463f375f76174ff6bfa8a6c95d7889e33e702156f7ec0d7628f9f37a1d062f0291367ee81025dd9989320d5d24c35b387
+DIST rosconsole-1.13.9.tar.gz 24798 BLAKE2B 1f6d86775affaaf889d51ae27673b3de826cf16a535867e90373d450d82d3e0ae8d1488fd2b4321462070bdf547f23d9ae464ebd2070c5a448e5b15548179d12 SHA512 cb2c47551c210f8d4b9d41f4b33a27599b5a22dff84344d0d564a5b9b2088cb2da8cc3afce97058a456c1dc4b7b8127fcaa8344f6110a40586d60f16278fd1ff
diff --git a/dev-ros/rosconsole/rosconsole-1.13.9.ebuild b/dev-ros/rosconsole/rosconsole-1.13.9.ebuild
new file mode 100644
index 000000000000..247659b7d3ab
--- /dev/null
+++ b/dev-ros/rosconsole/rosconsole-1.13.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rosconsole"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS console output library"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+log4cxx glog"
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/rosunit
+ dev-libs/boost:=[threads]
+ log4cxx? ( dev-libs/log4cxx )
+ !log4cxx? ( glog? ( dev-cpp/glog ) )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local ROSCONSOLE_BACKEND=""
+ if use log4cxx; then
+ ROSCONSOLE_BACKEND="log4cxx"
+ elif use glog; then
+ ROSCONSOLE_BACKEND="glog"
+ else
+ ROSCONSOLE_BACKEND="print"
+ fi
+ local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
+ ros-catkin_src_configure
+}