summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2015-10-26 20:18:36 +0000
committerSven Wegener <swegener@gentoo.org>2015-10-26 20:19:06 +0000
commit36625aa09597641918428449c73cfba530c3abd4 (patch)
tree2fa45c1db92e07841213c77f17ddc3a2e85e425c
parentsys-auth/oath-toolkit: Replace -Wall instead of -Werror (diff)
downloadgentoo-36625aa09597641918428449c73cfba530c3abd4.tar.gz
gentoo-36625aa09597641918428449c73cfba530c3abd4.tar.bz2
gentoo-36625aa09597641918428449c73cfba530c3abd4.zip
sys-auth/oath-toolkit: Version bump
Signed-off-by: Sven Wegener <swegener@gentoo.org>
-rw-r--r--sys-auth/oath-toolkit/Manifest1
-rw-r--r--sys-auth/oath-toolkit/oath-toolkit-2.6.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-auth/oath-toolkit/Manifest b/sys-auth/oath-toolkit/Manifest
index 684132144488..a836879abfc9 100644
--- a/sys-auth/oath-toolkit/Manifest
+++ b/sys-auth/oath-toolkit/Manifest
@@ -1 +1,2 @@
DIST oath-toolkit-2.4.1.tar.gz 4136649 SHA256 9bfa42cbc100eb6c43d2bf83e3badc51d9e6f4950a92e07513ae586d0c5e9b24 SHA512 2a3440d5c97afef00dacd235d5471e8bf68086dfdb20234a894e7534d75670808fef444fe1062525800bc5ffe368898302e6cf250cd76b7238cd602d7d05e89b WHIRLPOOL f74dc524a6845054f0d3126ac3a5555ca4ac8e5e70e108abc603622e8e73795e6cba81f3d39debca22a22c7c0f7aba133ec975acfbf8cf64a0b919f0ee1a802c
+DIST oath-toolkit-2.6.1.tar.gz 4238966 SHA256 9c57831907bc26eadcdf90ba1827d0bd962dd1f737362e817a1dd6d6ec036f79 SHA512 59feadbc06d11a52bf5879493227c40358fc1f4f17ec3ff92e3a313e47b92f3154396fa3ff38ef163852b32c8bfcef1f59753b614d0138478b8f7e7971f55e62 WHIRLPOOL 4c32514c265f430272d255eb6557f3b3d434c1700d4f6a5c3607808ba761d182dde679f9248b486f9e3c45d402d902bf4863b630d3415529303b2013aabe0223
diff --git a/sys-auth/oath-toolkit/oath-toolkit-2.6.1.ebuild b/sys-auth/oath-toolkit/oath-toolkit-2.6.1.ebuild
new file mode 100644
index 000000000000..131b04b3cd9e
--- /dev/null
+++ b/sys-auth/oath-toolkit/oath-toolkit-2.6.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit pam eutils autotools
+DESCRIPTION="Toolkit for using one-time password authentication with HOTP/TOTP algorithms"
+HOMEPAGE="http://www.nongnu.org/oath-toolkit/ http://gitorious.org/oath-toolkit/"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
+LICENSE="GPL-3 LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam pskc test"
+
+RDEPEND="
+ pam? ( virtual/pam )
+ pskc? ( dev-libs/xmlsec )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/libxml2 )
+ dev-util/gtk-doc-am"
+
+src_prepare() {
+ # These tests need git/cvs and don't reflect anything in the final app
+ sed -i -r \
+ -e '/TESTS/s,test-vc-list-files-(git|cvs).sh,,g' \
+ gl/tests/Makefile.am
+ # disable portability warnings, caused by gtk-doc.make
+ sed -i \
+ -e '/AM_INIT_AUTOMAKE/ s:-Wall:\0 -Wno-portability:' \
+ {liboath,libpskc}/configure.ac
+ eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable test xmltest ) \
+ $(use_enable pam) \
+ $(use_with pam pam-dir $(getpam_mod_dir)) \
+ $(use_enable pskc)
+}
+
+src_install() {
+ default
+ if use pam; then
+ newdoc pam_oath/README README.pam
+ fi
+ if use pskc; then
+ doman pskctool/pskctool.1
+ fi
+}
+
+src_test() {
+ # without keep-going, it will bail out after the first testsuite failure,
+ # skipping the other testsuites. as they are mostly independant, this sucks.
+ emake --keep-going check
+ [ $? -ne 0 ] && die "At least one testsuite failed"
+}