summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-28 17:22:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-28 20:10:14 +0100
commit3850571f38b8e1532c36e3d64296efadbd7e038e (patch)
tree207bf2ec25f9b51a0d677b25b48f39aaea5565ac
parentdev-ros/laser_proc: add missing := dep on console_bridge (diff)
downloadgentoo-3850571f38b8e1532c36e3d64296efadbd7e038e.tar.gz
gentoo-3850571f38b8e1532c36e3d64296efadbd7e038e.tar.bz2
gentoo-3850571f38b8e1532c36e3d64296efadbd7e038e.zip
sci-electronics/gazebo: fix build with tinyxml2-6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sci-electronics/gazebo/files/tinyxml6.patch20
-rw-r--r--sci-electronics/gazebo/gazebo-8.2.0.ebuild4
2 files changed, 22 insertions, 2 deletions
diff --git a/sci-electronics/gazebo/files/tinyxml6.patch b/sci-electronics/gazebo/files/tinyxml6.patch
new file mode 100644
index 000000000000..16a3862fc78f
--- /dev/null
+++ b/sci-electronics/gazebo/files/tinyxml6.patch
@@ -0,0 +1,20 @@
+Index: gazebo-8.2.0/gazebo/util/LogPlay.cc
+===================================================================
+--- gazebo-8.2.0.orig/gazebo/util/LogPlay.cc
++++ gazebo-8.2.0/gazebo/util/LogPlay.cc
+@@ -125,12 +125,9 @@ void LogPlay::Open(const std::string &_l
+ {
+ gzerr << "Unable to load file[" << _logFile << "]. "
+ << "Check the Gazebo server log file for more information.\n";
+- const char *errorStr1 = this->dataPtr->xmlDoc.GetErrorStr1();
+- const char *errorStr2 = this->dataPtr->xmlDoc.GetErrorStr2();
+- if (errorStr1)
+- gzlog << "Log Error 1:\n" << errorStr1 << std::endl;
+- if (errorStr2)
+- gzlog << "Log Error 2:\n" << errorStr2 << std::endl;
++ const char *errorStr = this->dataPtr->xmlDoc.ErrorStr();
++ if (errorStr)
++ gzlog << "Log Error:\n" << errorStr << std::endl;
+ gzthrow("Error parsing log file");
+ }
+
diff --git a/sci-electronics/gazebo/gazebo-8.2.0.ebuild b/sci-electronics/gazebo/gazebo-8.2.0.ebuild
index 923dd8c7c2f2..04696aa2fb5f 100644
--- a/sci-electronics/gazebo/gazebo-8.2.0.ebuild
+++ b/sci-electronics/gazebo/gazebo-8.2.0.ebuild
@@ -21,7 +21,7 @@ RDEPEND="
media-libs/openal
net-misc/curl
dev-libs/tinyxml
- dev-libs/tinyxml2:=
+ >=dev-libs/tinyxml2-6:=
dev-libs/libtar
dev-cpp/tbb
>=dev-games/ogre-1.7.4[freeimage]
@@ -57,7 +57,7 @@ DEPEND="${RDEPEND}
test? ( dev-libs/libxslt )
"
CMAKE_BUILD_TYPE=RelWithDebInfo
-PATCHES=( "${FILESDIR}/qwt.patch" )
+PATCHES=( "${FILESDIR}/qwt.patch" "${FILESDIR}/tinyxml6.patch" )
src_configure() {
# doesnt build without it