summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-03-02 20:16:22 +0000
committerJustin Lecher <jlec@gentoo.org>2016-03-02 20:44:39 +0000
commit392cd06ebc6ac9fc6a93f70e975b39c51f039a8e (patch)
tree93fe3d5c400516b831d9dc0145b9f61d6c828724
parentdev-python/ipython: Break circular dependency with dev-python/qtconsole (diff)
downloadgentoo-392cd06ebc6ac9fc6a93f70e975b39c51f039a8e.tar.gz
gentoo-392cd06ebc6ac9fc6a93f70e975b39c51f039a8e.tar.bz2
gentoo-392cd06ebc6ac9fc6a93f70e975b39c51f039a8e.zip
sci-libs/mkl: Properly check for free disk space
Gentoo-Bugs: https://bugs.gentoo.org/show_bug.cgi?id=576044 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-libs/mkl/mkl-10.0.5.025.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sci-libs/mkl/mkl-10.0.5.025.ebuild b/sci-libs/mkl/mkl-10.0.5.025.ebuild
index 4978b615c527..f49e232c5672 100644
--- a/sci-libs/mkl/mkl-10.0.5.025.ebuild
+++ b/sci-libs/mkl/mkl-10.0.5.025.ebuild
@@ -31,6 +31,8 @@ RDEPEND="${DEPEND}
MKL_DIR=/opt/intel/${PN}/${PV}
INTEL_LIC_DIR=/opt/intel/licenses
+CHECKREQS_DISK_BUILD=3500M
+
QA_PREBUILT="opt/intel/${PN}/${PV}/*"
get_fcomp() {
@@ -45,6 +47,7 @@ get_fcomp() {
}
pkg_setup() {
+ check-reqs_pkg_setup
fortran-2_pkg_setup
# Check the license
if [[ -z ${MKL_LICENSE} ]]; then
@@ -89,6 +92,8 @@ pkg_setup() {
}
src_prepare() {
+ check-reqs_src_prepare
+
cd l_${PN}_*_${PV}/install || die
cp ${MKL_LICENSE} "${WORKDIR}"/ || die