summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-05 15:16:17 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-05 15:28:59 +0100
commit3989919258db66312b9eb0330f09878312e8f65b (patch)
tree83dcbbd81c28da65246b8eade4ba014a74105c75
parentdev-libs/libmirage: Bump to 3.2.1 (diff)
downloadgentoo-3989919258db66312b9eb0330f09878312e8f65b.tar.gz
gentoo-3989919258db66312b9eb0330f09878312e8f65b.tar.bz2
gentoo-3989919258db66312b9eb0330f09878312e8f65b.zip
app-cdr/cdemu-daemon: Bump to 3.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-cdr/cdemu-daemon/Manifest1
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.2.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
index df95cd81978c..c2be8990586d 100644
--- a/app-cdr/cdemu-daemon/Manifest
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -1 +1,2 @@
DIST cdemu-daemon-3.2.1.tar.bz2 82426 BLAKE2B 282b1a62ca3a770e709ff31ee7b72ed9f5e102c5f318a765a99421c93881e9ecacfdc5867af494e69dddda40603c8eb6cc8904a7c82fec004a6d5644a28a9f87 SHA512 399dbb818de8a550bd31784a5a7f0adb9d2e35d922ba71f341df81d20fd7e5ebaba5f31db1554caca17919325773f9ec6bb3d5ae99afa5d6eaf5b22142e010ee
+DIST cdemu-daemon-3.2.2.tar.bz2 82366 BLAKE2B d21436a5dbf1c6d953aa7ceb58e5d4580931391ea407c45de8f7c7154c181aef76535833bf02999d77d3a9e0c624db1124a9d333d028e206844a1256b3c5dde0 SHA512 4010bad27d5f595d20e1666700d32c2fb3f943f2e50645317bcc8fbbbba58cd61b3f6d3276e91fff55f449e44291abc776a56ded7c4f0bb7901ac247da72d7fe
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.2.2.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.2.ebuild
new file mode 100644
index 000000000000..08e6bd4b49a2
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/glib-2.38:2
+ >=dev-libs/libmirage-3.2.0:=
+ >=media-libs/libao-0.8.0:="
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+
+DOCS=( AUTHORS README )
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT%/}/etc/conf.d/cdemud"
+ fi
+}