summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-14 15:36:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-14 15:36:11 +0200
commit39f0ec6b35c3170d809d22dc66cb3233fb7ed3d2 (patch)
treed30684b782e49518c243156d99f7256b3e65d2c3
parentmedia-libs/vamp-plugin-sdk: add multilib build dep on libsndfile, bug #596906 (diff)
downloadgentoo-39f0ec6b35c3170d809d22dc66cb3233fb7ed3d2.tar.gz
gentoo-39f0ec6b35c3170d809d22dc66cb3233fb7ed3d2.tar.bz2
gentoo-39f0ec6b35c3170d809d22dc66cb3233fb7ed3d2.zip
dev-ros/tf: backport upstream patch to build with gcc6, bug #593938, patch by Peter Levine
Package-Manager: portage-2.3.2
-rw-r--r--dev-ros/tf/files/gcc6.patch22
-rw-r--r--dev-ros/tf/tf-1.11.8.ebuild3
2 files changed, 24 insertions, 1 deletions
diff --git a/dev-ros/tf/files/gcc6.patch b/dev-ros/tf/files/gcc6.patch
new file mode 100644
index 000000000000..72b32bd1172e
--- /dev/null
+++ b/dev-ros/tf/files/gcc6.patch
@@ -0,0 +1,22 @@
+commit b0d31cc1e9a43b45d216ee7f804e901a5c0f8936
+Author: Hodorgasm <nsane457@gmail.com>
+Date: Mon Sep 19 17:58:22 2016 -0400
+
+ Fix "stdlib.h: No such file or directory" errors in GCC-6
+
+ Including '-isystem /usr/include' breaks building with GCC-6.
+ See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129
+
+diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
+index 8077561..cf72127 100644
+--- a/tf/CMakeLists.txt
++++ b/tf/CMakeLists.txt
+@@ -8,7 +8,7 @@ find_package(catkin COMPONENTS angles geometry_msgs message_filters message_gene
+
+ catkin_python_setup()
+
+-include_directories(SYSTEM ${Boost_INCLUDE_DIR}
++include_directories(${Boost_INCLUDE_DIR}
+ ${catkin_INCLUDE_DIRS}
+ )
+ include_directories(include)
diff --git a/dev-ros/tf/tf-1.11.8.ebuild b/dev-ros/tf/tf-1.11.8.ebuild
index f81e4ccc6abe..573a9d8ab688 100644
--- a/dev-ros/tf/tf-1.11.8.ebuild
+++ b/dev-ros/tf/tf-1.11.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -37,3 +37,4 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
dev-python/nose[${PYTHON_USEDEP}]
)"
+PATCHES=( "${FILESDIR}/gcc6.patch" )