summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-21 21:38:16 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-21 21:40:35 +0200
commit3aeec3b3bf290469fa22f8c04ea5edbc2120da96 (patch)
treefde2ff080342bc9553be6eea3b06e4484ef3e7c5
parentsys-devel/clang-runtime: -9.0.9999 → -9.0.0.9999 (diff)
downloadgentoo-3aeec3b3bf290469fa22f8c04ea5edbc2120da96.tar.gz
gentoo-3aeec3b3bf290469fa22f8c04ea5edbc2120da96.tar.bz2
gentoo-3aeec3b3bf290469fa22f8c04ea5edbc2120da96.zip
dev-util/lldb: -10.0.0 no longer builds the readline module
Remove readline.so removal since the extension is no longer present in git. It probably isn't present in -9.0.0 as well but I want to be able to test it first. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/lldb/lldb-10.0.0.9999.ebuild12
1 files changed, 1 insertions, 11 deletions
diff --git a/dev-util/lldb/lldb-10.0.0.9999.ebuild b/dev-util/lldb/lldb-10.0.0.9999.ebuild
index 537fb0c30af1..b28959dc3c26 100644
--- a/dev-util/lldb/lldb-10.0.0.9999.ebuild
+++ b/dev-util/lldb/lldb-10.0.0.9999.ebuild
@@ -106,15 +106,5 @@ src_test() {
src_install() {
cmake-utils_src_install
- # oh my...
- if use python; then
- # remove custom readline.so for now
- # TODO: figure out how to deal with it
- # upstream is basically building a custom readline.so with -ledit
- # to avoid symbol collisions between readline and libedit...
- rm "${D}$(python_get_sitedir)/readline.so" || die
-
- # byte-compile the modules
- python_optimize
- fi
+ use python && python_optimize
}