summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-07-21 10:23:13 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-07-21 10:23:13 +0200
commit3e2029723e74b41593d8647ba027db53f976780b (patch)
tree5ffc2143bbabb7b6bf6f818e5c02abc28f5cb750
parentx11-wm/lumina: drop unneeded dependency on icon-themes (diff)
downloadgentoo-3e2029723e74b41593d8647ba027db53f976780b.tar.gz
gentoo-3e2029723e74b41593d8647ba027db53f976780b.tar.bz2
gentoo-3e2029723e74b41593d8647ba027db53f976780b.zip
dev-libs/libinput: version bump to 1.8.1
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.8.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 30bce5307fc2..849d11698810 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -2,3 +2,4 @@ DIST libinput-1.6.2.tar.xz 929180 SHA256 96fc0e0b24a96042b16e561201979dfa4a3f00a
DIST libinput-1.7.2.tar.xz 923720 SHA256 0b1e5a6c106ccc609ccececd9e33e6b27c8b01fc7457ddb4c1dd266e780d6bc2 SHA512 cdbd2994e954aac9538fe907c275e6e23e2bed0e9c4c65f19591bdcdbf5074131c72b92e87de87c03f75a991fcdb7f568b491a12f00031c4eba11082ca44d69f WHIRLPOOL 869623f2ef8da44627f28552f86583a6e6927f4966489f1c59d4b7c5061983d58744be5ea162a97e07e4a79495f56a728faaa273f8d45a8a2ee242819769aae8
DIST libinput-1.7.3.tar.xz 922464 SHA256 096d612d2711f0caa2de544976ff3729e6233511ab373808644cc2dd5affcb1d SHA512 2262dc56d213a4d3ea765e870af200e2c336a166baa1bbdf5205e3ce70faefc777429ba09563c5dd79feb5442f53abc84e04a0f32a06bb622d6e120bb8ad152b WHIRLPOOL 06ea9038f7b3127b3238fc863b1ec862647a08b1ab4956fcfd433093dc3c68585ba3b166515370681ed158a48ce6a5670c6b8dcb6d536af25f8bda2c84c74286
DIST libinput-1.8.0.tar.xz 939708 SHA256 f8c9dbc31bf549008486258ebfa328d3dbc749c0029c6168e46949c24cf19076 SHA512 84354859c25cf2906214fd195c396e8166db361664edc625db5aab4f1b247dfc4a80d7e9dffe2b61c6bbfaa8208d3f64ce56aac2180a699cb71a088d6196ba4d WHIRLPOOL 03f8d54cef162e17ede58ee1b2697323700f430c393c8c001494b9b0e881fed828ba99ca79b4547382b59be9771348628373e89096f6e936ad225bf68915901b
+DIST libinput-1.8.1.tar.xz 936292 SHA256 e3590a9037e561a5791c8bd3b34bfd30fad5cacd8cbefc0d75fafe3a41d07147 SHA512 1566ccb7d1721ee2d16badc404896d31e3ac45fda71e2577db17141a507594f3827ed0a389bb537f946cb380d77feedef8e71df76ac89f8c11c44463df01ee4f WHIRLPOOL b519b447aa775280eb107933c1599dfefd132bbf51438f9337fcf286783dc20d599ce6fa2563da802b6da6874ad68c99c171204c0771f4faa649924ee00458d0
diff --git a/dev-libs/libinput/libinput-1.8.1.ebuild b/dev-libs/libinput/libinput-1.8.1.ebuild
new file mode 100644
index 000000000000..0c88be02d470
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.8.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_prepare() {
+ default
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-debug-gui \
+ --disable-documentation \
+ $(use_enable input_devices_wacom libwacom) \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}