summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 07:48:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:06 +0200
commit3f8f8b4103425850ae54ecdcdd7f1833e2b0d5ca (patch)
tree182e550b19bd120a5424656eeeebca1a525ecabb
parentdev-ros/rqt_publisher: remove old (diff)
downloadgentoo-3f8f8b4103425850ae54ecdcdd7f1833e2b0d5ca.tar.gz
gentoo-3f8f8b4103425850ae54ecdcdd7f1833e2b0d5ca.tar.bz2
gentoo-3f8f8b4103425850ae54ecdcdd7f1833e2b0d5ca.zip
dev-ros/rqt_publisher: bump to 0.4.8 and update to split repos
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ros/rqt_publisher/Manifest1
-rw-r--r--dev-ros/rqt_publisher/metadata.xml2
-rw-r--r--dev-ros/rqt_publisher/rqt_publisher-0.4.8.ebuild27
-rw-r--r--dev-ros/rqt_publisher/rqt_publisher-9999.ebuild5
4 files changed, 31 insertions, 4 deletions
diff --git a/dev-ros/rqt_publisher/Manifest b/dev-ros/rqt_publisher/Manifest
index 7bb8c4d74093..0b26861c84e8 100644
--- a/dev-ros/rqt_publisher/Manifest
+++ b/dev-ros/rqt_publisher/Manifest
@@ -1 +1,2 @@
DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
+DIST rqt_publisher-0.4.8.tar.gz 10391 SHA256 ee0844e85b264187fac4f6442ff6d443e32d475ddea022a74a08b489d7613a05 SHA512 87a325c9599b68171f5e014524946ab0a311872035c8b23a7234f17854d7e7f91916a6db856331b5e9958d098197b55a2e799a5b0d232bb32dd420acd070421e WHIRLPOOL 120d97bf3a2eea6858df6e8b3b24b249dde4446d25522f9f040c1510108564dbe97adf7a5965619d199b1b4ef513387a741b1d60448af1ddf88c9cbe42a6cce1
diff --git a/dev-ros/rqt_publisher/metadata.xml b/dev-ros/rqt_publisher/metadata.xml
index cb473d142b8e..db9114451292 100644
--- a/dev-ros/rqt_publisher/metadata.xml
+++ b/dev-ros/rqt_publisher/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_common_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_publisher</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_publisher/rqt_publisher-0.4.8.ebuild b/dev-ros/rqt_publisher/rqt_publisher-0.4.8.ebuild
new file mode 100644
index 000000000000..b4dc8d08ed02
--- /dev/null
+++ b/dev-ros/rqt_publisher/rqt_publisher-0.4.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_publisher"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for publishing arbitrary messages with fixed or computed field values"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild b/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild
index 74c5df405502..b4dc8d08ed02 100644
--- a/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild
+++ b/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_publisher"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin