summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-05 14:06:25 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-05 14:11:29 +0200
commit429586932667489b0aee11eafe10f293afe456b3 (patch)
tree2f1aca5b78bbb85bc1f005abc7965b6874ca4e49
parentapp-text/dictd: Clean up patch (diff)
downloadgentoo-429586932667489b0aee11eafe10f293afe456b3.tar.gz
gentoo-429586932667489b0aee11eafe10f293afe456b3.tar.bz2
gentoo-429586932667489b0aee11eafe10f293afe456b3.zip
app-text/dictd: Version 1.13.0
- EAPI=7, readme.gentoo-r1 - Make sed die - Use --libexecdir[sic!] for plugins directory - Install all examples - Remove static libraries/libtool files Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--app-text/dictd/Manifest1
-rw-r--r--app-text/dictd/dictd-1.13.0.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/app-text/dictd/Manifest b/app-text/dictd/Manifest
index 303b1f6ceb7b..998e4a4f7daa 100644
--- a/app-text/dictd/Manifest
+++ b/app-text/dictd/Manifest
@@ -1 +1,2 @@
DIST dictd-1.12.1.tar.gz 423870 BLAKE2B 9a1522a9786fac732c5e8b481b2eaa36d75ab27d3388e40cdf80016a410123907c4b28b1ed32c1fa3b179b27a358447625de6c0c1e9ab9f35c6d5d3f16591b9f SHA512 51bceba36f9e34ffcbbf42a6235aab6097fe66ba8ed086ea60d0df8b7daf91c6449fdf7c5605150c77035d98029053233db106f9188786b30e02ecd61748209b
+DIST dictd-1.13.0.tar.gz 395455 BLAKE2B 222ce7eee03083ee23066f43330cce0cda3041d2ee4a0d54b2e9f2ea18a77ec83f91fbb766bdad645bdcaeed0674361ba600a393e4cb6c42bab6be94098991f0 SHA512 86871aaf34a182d1d7aac1a1282d4a75f2d7c112c762e92f303924c324f665dae75c51e7ca91e3cc1dde2053ad8e2d1fd50a76934a5f84ff70975aa858e26439
diff --git a/app-text/dictd/dictd-1.13.0.ebuild b/app-text/dictd/dictd-1.13.0.ebuild
new file mode 100644
index 000000000000..c34a460822b0
--- /dev/null
+++ b/app-text/dictd/dictd-1.13.0.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1 systemd user
+
+DESCRIPTION="Dictionary Client/Server for the DICT protocol"
+HOMEPAGE="http://www.dict.org/ https://sourceforge.net/projects/dict/"
+SRC_URI="mirror://sourceforge/dict/${P}.tar.gz"
+
+SLOT="0"
+# We install rfc so - ISOC-rfc
+LICENSE="GPL-2 ISOC-rfc"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="dbi judy minimal"
+
+# <gawk-3.1.6 makes tests fail.
+RDEPEND="
+ >=sys-apps/coreutils-6.10
+ dev-libs/libmaa
+ sys-libs/zlib
+ dbi? ( dev-db/libdbi )
+ judy? ( dev-libs/judy )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ >=sys-apps/gawk-3.1.6
+ virtual/yacc
+"
+
+DOC_CONTENTS="
+ To start and use ${PN} you need to emerge at least one dictionary from
+ the app-dicts category with the package name starting with 'dictd-'.
+ To install all available dictionaries, emerge app-dicts/dictd-dicts.
+ ${PN} will NOT start without at least one dictionary.\n
+ \nIf you are running systemd, you will need to review the instructions
+ explained in /etc/dict/dictd.conf comments.
+"
+PATCHES=(
+ "${FILESDIR}"/dictd-1.10.11-colorit-nopp-fix.patch
+ "${FILESDIR}"/dictd-1.12.0-build.patch
+)
+
+pkg_setup() {
+ enewgroup dictd # used in src_test()
+ enewuser dictd -1 -1 -1 dictd
+}
+
+src_prepare() {
+ default
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ sed -i -e 's:libtool:glibtool:g' Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_with dbi plugin-dbi) \
+ $(use_with judy plugin-judy) \
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)/${PN} \
+ --sysconfdir="${EPREFIX}"/etc/dict
+}
+
+src_compile() {
+ if use minimal; then
+ emake dictfmt dictzip dictzip
+ else
+ emake
+ fi
+}
+
+src_test() {
+ use minimal && return 0 # All tests are for dictd which we don't build...
+ if [[ ${EUID} -eq 0 ]]; then
+ # If dictd is run as root user (-userpriv) it drops its privileges to
+ # dictd user and group. Give dictd group write access to test directory.
+ chown :dictd "${WORKDIR}" "${S}/test"
+ chmod 770 "${WORKDIR}" "${S}/test"
+ fi
+ emake test
+}
+
+src_install() {
+ if use minimal; then
+ emake DESTDIR="${D}" install.dictzip install.dict install.dictfmt
+ else
+ default
+
+ dodoc doc/{dicf.ms,rfc.ms,rfc.sh,rfc2229.txt}
+ dodoc doc/{security.doc,toc.ms}
+ dodoc -r examples
+
+ # conf files. For dict.conf see below.
+ insinto /etc/dict
+ for f in dictd.conf site.info colorit.conf; do
+ doins "${FILESDIR}/1.10.11/${f}"
+ done
+
+ # startups for dictd
+ newinitd "${FILESDIR}/1.10.11/dictd.initd" dictd
+ newconfd "${FILESDIR}/1.10.11/dictd.confd" dictd
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ fi
+
+ find "${ED}" -name '*.la' -o -name '*.a' -delete || die
+
+ insinto /etc/dict
+ doins "${FILESDIR}"/1.10.11/dict.conf
+
+ dodoc ANNOUNCE NEWS README TODO
+
+ readme.gentoo_create_doc
+}