summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-09 11:02:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-09 11:02:39 +0200
commit458b1724bf54155f49ee4a729a30a2904109efd0 (patch)
tree0b2b05b0469d4f9ec20fbe898f2178f5d059320b
parentwww-client/vivaldi-snapshot: Old (diff)
downloadgentoo-458b1724bf54155f49ee4a729a30a2904109efd0.tar.gz
gentoo-458b1724bf54155f49ee4a729a30a2904109efd0.tar.bz2
gentoo-458b1724bf54155f49ee4a729a30a2904109efd0.zip
dev-python/docutils: Revbump to drop py2.7
Closes: https://bugs.gentoo.org/722762 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/docutils/docutils-0.16-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/docutils/docutils-0.16-r1.ebuild b/dev-python/docutils/docutils-0.16-r1.ebuild
new file mode 100644
index 000000000000..1e418f79f501
--- /dev/null
+++ b/dev-python/docutils/docutils-0.16-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Documentation Utilities"
+HOMEPAGE="https://docutils.sourceforge.net/ https://pypi.org/project/docutils/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-3 public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tests.patch
+)
+
+python_compile_all() {
+ # Generate html docs from reStructured text sources.
+
+ # Place html4css1.css in base directory to ensure that the generated reference to it is correct.
+ cp docutils/writers/html4css1/html4css1.css . || die
+
+ cd tools || die
+ "${EPYTHON}" buildhtml.py --input-encoding=utf-8 \
+ --stylesheet-path=../html4css1.css, --traceback ../docs || die
+}
+
+src_test() {
+ cd test || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" alltests.py -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Install tools.
+ python_doscript tools/{buildhtml,quicktest}.py
+}
+
+install_txt_doc() {
+ local doc="${1}"
+ local dir="txt/$(dirname ${doc})"
+ docinto "${dir}"
+ dodoc "${doc}"
+}
+
+python_install_all() {
+ local DOCS=( *.txt )
+ local HTML_DOCS=( docs tools docutils/writers/html4css1/html4css1.css )
+
+ distutils-r1_python_install_all
+
+ local doc
+ while IFS= read -r -d '' doc; do
+ install_txt_doc "${doc}"
+ done < <(find docs tools -name '*.txt' -print0)
+}