summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-06-14 08:41:39 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-06-14 08:41:39 +0200
commit4720d4222ecc8b8b3af42a7f0bce7dc5959d9915 (patch)
tree48227cf7be5851de1fe99acbd9e36fb9ad7abf53
parentdev-ada/asis: remove an old version (diff)
downloadgentoo-4720d4222ecc8b8b3af42a7f0bce7dc5959d9915.tar.gz
gentoo-4720d4222ecc8b8b3af42a7f0bce7dc5959d9915.tar.bz2
gentoo-4720d4222ecc8b8b3af42a7f0bce7dc5959d9915.zip
dev-ada/xmlada: removing an old version
Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
-rw-r--r--dev-ada/xmlada/xmlada-2018-r1.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/dev-ada/xmlada/xmlada-2018-r1.ebuild b/dev-ada/xmlada/xmlada-2018-r1.ebuild
deleted file mode 100644
index 48988109dcfc..000000000000
--- a/dev-ada/xmlada/xmlada-2018-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multiprocessing
-
-MYP=${PN}-gpl-${PV}
-
-DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
-HOMEPAGE="http://libre.adacore.com/"
-SRC_URI="http://mirrors.cdn.adacore.com/art/591aeb88c7a4473fcbb154f8 ->
- ${MYP}-src.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gnat_2016 gnat_2017 +gnat_2018 gnat_2019 +shared static-libs static-pic"
-REQUIRED_USE="|| ( shared static-libs static-pic )
- ^^ ( gnat_2016 gnat_2017 gnat_2018 gnat_2019 )"
-
-RDEPEND="gnat_2016? ( dev-lang/gnat-gpl:4.9.4 )
- gnat_2017? ( dev-lang/gnat-gpl:6.3.0 )
- gnat_2018? ( dev-lang/gnat-gpl:7.3.1 )
- gnat_2019? ( dev-lang/gnat-gpl:8.3.1 )"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[gnat_2016(-)?,gnat_2017(-)?,gnat_2018(-)?,gnat_2019(-)?]"
-
-S="${WORKDIR}"/${MYP}-src
-
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-
-src_configure () {
- econf --prefix="${D}"/usr
-}
-
-src_compile () {
- build () {
- gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
- -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
- -cargs ${ADAFLAGS} || die "gprbuild failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-}
-
-src_test() {
- emake test
- emake run_test | grep DIFF && die
-}
-
-src_install () {
- build () {
- gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
- -XPROCESSORS=$(makeopts_jobs) --prefix="${D}"usr \
- --install-name=xmlada --build-var=LIBRARY_TYPE \
- --build-var=XMLADA_BUILD \
- --build-name=$1 xmlada.gpr || die "gprinstall failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-
- einstalldocs
- dodoc xmlada-roadmap.txt
- rm "${D}"/usr/share/doc/${PN}/.buildinfo || die
- rm -r "${D}"/usr/share/gpr/manifests || die
-}