summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-03-24 21:37:24 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-03-25 00:17:58 +0000
commit47879bafb12ce8ca10959d2831f5090f8d89e679 (patch)
tree8c73103abbeb899638c9302b8e882b2113c7ae01
parentsys-kernel/raspberrypi-image: inherit mount-boot (diff)
downloadgentoo-47879bafb12ce8ca10959d2831f5090f8d89e679.tar.gz
gentoo-47879bafb12ce8ca10959d2831f5090f8d89e679.tar.bz2
gentoo-47879bafb12ce8ca10959d2831f5090f8d89e679.zip
sys-kernel/raspberrypi-image: drop pkg_preinst
The first part of it is useless because it is about installing config.txt and cmdline.txt, which this package doesn't do. The second part is a check for /boot being mounted. This is done by mount-boot eclass nowadays. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
-rw-r--r--sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild23
1 files changed, 0 insertions, 23 deletions
diff --git a/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild b/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild
index dd395d591b0c..a18735fa66e3 100644
--- a/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild
+++ b/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild
@@ -19,29 +19,6 @@ DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
RESTRICT="binchecks strip"
-pkg_preinst() {
- if [ -z "${REPLACING_VERSIONS}" ] ; then
- local msg=""
- if [ -e "${D}"/boot/cmdline.txt -a -e "${ROOT}"/boot/cmdline.txt ] ; then
- msg+="/boot/cmdline.txt "
- fi
- if [ -e "${D}"/boot/config.txt -a -e "${ROOT}"/boot/config.txt ] ; then
- msg+="/boot/config.txt "
- fi
- if [ -n "${msg}" ] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove(backup) your copies during install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
-
- if ! grep "${ROOT}boot" /proc/mounts >/dev/null 2>&1; then
- ewarn "${ROOT}boot is not mounted, the files might not be installed at the right place"
- fi
-}
-
src_configure() { :; }
src_compile() { :; }