summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2021-03-13 07:52:05 -0700
committerChristoph Junghans <junghans@gentoo.org>2021-03-14 13:15:01 -0600
commit4c4eeb78f9c399a7d22fdc728a2f4fec93e91265 (patch)
tree612554b7a16e4fc2e494d1fa9134d24d990a0306
parentdev-ml/seq: remove unused patch(es) (diff)
downloadgentoo-4c4eeb78f9c399a7d22fdc728a2f4fec93e91265.tar.gz
gentoo-4c4eeb78f9c399a7d22fdc728a2f4fec93e91265.tar.bz2
gentoo-4c4eeb78f9c399a7d22fdc728a2f4fec93e91265.zip
sci-libs/votca-tools: version bump
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
-rw-r--r--sci-libs/votca-tools/Manifest1
-rw-r--r--sci-libs/votca-tools/votca-tools-2021.ebuild42
-rw-r--r--sci-libs/votca-tools/votca-tools-9999.ebuild5
3 files changed, 45 insertions, 3 deletions
diff --git a/sci-libs/votca-tools/Manifest b/sci-libs/votca-tools/Manifest
index 4f17ce0eb386..f54cf8590f65 100644
--- a/sci-libs/votca-tools/Manifest
+++ b/sci-libs/votca-tools/Manifest
@@ -2,3 +2,4 @@ DIST votca-tools-1.5.1.tar.gz 129629 BLAKE2B ab68b38241d2c065939cf0b2e08603eaacc
DIST votca-tools-1.6.2.tar.gz 109808 BLAKE2B 1eebb2950004ec5b0a0494904b35f5dc539a5a93e36d40ffdfba911632e48ef9431bfd8d6305c0b5f516c70cff8156976efa6d216ae061a77e018047e543beee SHA512 03139591e934ae97b6c0ddcd0fa9480b4b9d28c05882489b9067b9519727a97a1589a645c3d9ad959d65fa622e3845e8d1d5141f210e2704907d7d6f0bff2abc
DIST votca-tools-1.6.4.tar.gz 109929 BLAKE2B 8bc55fcd0a021002f11d412440a369a169c3c62ae5978781010de0a05502e43ed1ccbe5066e3d46ac8ef6fd0c1471baca70d35f6468ccbfd480dc0fa6f2b5047 SHA512 7a334071086e755960a3bd938c1baa1979c4cc9cd8f865af00540fa45365bf1c3153ffb8a5a5948618c47ebafcda9ecc62850d44ea06b7f35ac4587bd423439a
DIST votca-tools-1.6.tar.gz 109824 BLAKE2B e030899e210e0f3030d43796a468ea20a573fe7ee62fbfde53e2e6865a9c0657d92ed06ddc44ebfa1c37c6142c865e97380e00570070351d75c403ead6fcfd19 SHA512 0159bc10066e05da8ba0f70e3c70d8cb4cd7b07ebd58edff1ccfeb86504af855eb5cae7184200e5c8ee3a3f6b6b85ec46a045f00dc8e681073ae8fdbbfc3965a
+DIST votca-tools-2021.tar.gz 114974 BLAKE2B 9f707a901b83f0d8a6c7e5c9b43b135c7539cf4f1fa44a4ed1a5c8f2f7066e1241515fc025ea436f2e52e6bf4aefb7c9a15575e8a588845dda7fbb6717f50b7e SHA512 5ddcbe49b1898713fa292655efbb2a1c081a7f98c9bae3ef37b273e0db49eecb3800b865221883d610802923132d57d5847cc35ddb008de4eb180f4c30db3dbf
diff --git a/sci-libs/votca-tools/votca-tools-2021.ebuild b/sci-libs/votca-tools/votca-tools-2021.ebuild
new file mode 100644
index 000000000000..50be2b65e3b2
--- /dev/null
+++ b/sci-libs/votca-tools/votca-tools-2021.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+ S="${WORKDIR}/${P#votca-}"
+fi
+
+DESCRIPTION="Votca tools library"
+HOMEPAGE="https://www.votca.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-cpp/eigen-3.3
+ dev-libs/boost:=
+ dev-libs/expat
+ sci-libs/fftw:3.0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+DOCS=( NOTICE README.rst CHANGELOG.rst )
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_RC_FILES=OFF
+ )
+ cmake_src_configure
+}
diff --git a/sci-libs/votca-tools/votca-tools-9999.ebuild b/sci-libs/votca-tools/votca-tools-9999.ebuild
index 21ffc1d3bbaf..50be2b65e3b2 100644
--- a/sci-libs/votca-tools/votca-tools-9999.ebuild
+++ b/sci-libs/votca-tools/votca-tools-9999.ebuild
@@ -29,15 +29,14 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="
- >=app-text/txt2tags-2.5
virtual/pkgconfig
"
-DOCS=( NOTICE )
+DOCS=( NOTICE README.rst CHANGELOG.rst )
src_configure() {
local mycmakeargs=(
- -DWITH_RC_FILES=OFF
+ -DINSTALL_RC_FILES=OFF
)
cmake_src_configure
}